25

Just to make sure that nobody looses two hours trying to fix this. You do not need to change anything in the sources.list anymore. Install GStreamer with: sudo apt-get install gstreamer1.0-tools


3

It turns out this issue had to do with having called tvservice to change the screen resolution. Apparently after this is done a corresponding call needs to be made to fbset. So for example if I go to DMT mode 16 (1920x1080): tvservice -e "DMT 16 I need to follow that up with: fbset -g 1920 1080 1920 1080 16 Now fbdevsink works. omxplayer seems to work ...


3

Try: gst-launch-1.0 v4l2src device=/dev/video0 ! videoconvert ! ximagesink


2

tl;dr Start with fresh Raspbian and do not alter /etc/apt/sources.list to install GStreamer. Trying to fix APT repository is possible, but usually time-consuming task. You can install GStreamer from the official repositories (as suggested in this answer): sudo apt-get install gstreamer1.0-tools Regarding your question: you need to add space between . and ...


2

Please add videoconvert after appsrc as you need to convert format of the video to display it on autovideosink or stream it using udpsink. It could be something like this: video = cv2.VideoWriter('appsrc ! queue ! videoconvert ! video/x-raw ! omxh264enc ! video/x-h264 ! h264parse ! rtph264pay ! udpsink host=192.168.0.2 port=5000 sync=false',0,25.0,(640,480))...


2

I was facing the same problem. Found out that Video and GLVideo from contribution manager not working anymore, instead I downloaded Video library from Github and now examples from Video library are working, but slow. Also, in the GLVideo examples I replaced the GLVideo for Video. Check this thread also


2

Actually, I was think that problem is related to Raspberry Pi but it wasn't. Somehow, OpenCV doesn't recognize GStreamer library when building OpenCV with cmake and make. Also when I use OpenCV in C++ code stack, OpenCV didn't throw exception when it couldn't find gstreamer support. I added -D WITH_GSTREAMER=ON flag when I'm using cmake command. You can find ...


2

It's resolved. I deleted all gst binaries and libraries and reinstall them. Thanks anyway. This is the command I used : apt-get install epiphany-browser evince gir1.2-gstreamer-1.0 gnome-user-guide gstreamer1.0-omx gstreamer1.0-omx-rpi gstreamer1.0-plugins-bad gstreamer1.0-plugins-base gstreamer1.0-plugins-good gstreamer1.0-tools gstreamer1.0-x ...


1

LoRa is NOT intended to be used for such a thing. LoRa operates in the free ISM band. As such there are rules that don't allow transmission over a long period (the maximum allowed transmission time is regulated by the local government) in order to allow other devices to also use the shared medium - thus reducing the air-time. Also LoRa uses transmission ...


1

Figured it out! It works fine on my pi cam because it supported H264 natviely. You could check the format supported by the webcam by doing: v4l2-ctl --list-formats-ext -d /dev/video0 For my webcam, it only supports YUYV and MJPEG: v4l2-ctl --list-formats-ext -d /dev/video0: pi@raspberrypi:~ $ v4l2-ctl --list-formats-ext -d /dev/video0 ioctl: ...


1

After a lot of research we have got to the following solution: gst-launch-1.0 tcpclientsrc host=192.168.1.2 port=5000 num-buffers=100000 ! gdpdepay ! jpegparse ! jpegdec ! videoconvert ! pngenc snapshot=true ! filesink location=a.png


1

I have found that the solution mentioned in https://www.linux-projects.org/uv4l/installation/ works well. Out-of-the box, the video will have a text overlay, but if you give a "contribution" of $15 or so, and email the author, you can get a key that removes the text. I'm getting low-latency (0.5 sec or so) video at 1280 X 960 @ 30fps from a Model 3B ...


1

Ok, finally I have two options for converting .ts file. First option is with audio conversion: gst-launch-1.0 filesrc location=1.ts \ ! tsdemux parse-private-sections=false name=demux \ ! queue max-size-buffers=0 max-size-time=0 \ ! mpegaudioparse \ ! mpg123audiodec \ ! audioconvert dithering=0 \ ! audio/x-raw,channels=2 \ ! avenc_aac compliance=-2 bitrate=...


1

The glimagesink seems to have a problem with Raspbian running xserver. Using Raspbian Light with glimagesink works like a charm. So no need for the "hello_video" workaround. So the final pipeline is: Sender: gst-launch-1.0 v4l2src ! 'video/x-v264,width=1920,height=1080,framerate=30/1' ! h264parse config-interval=1 ! rtph264pay ! udpsink host=10.0.0.129 port=...


1

If you load the v4l2 driver sudo modprobe bcm2835-v4l2 instead of raspivid and try gst-launch-1.0 v4l2src ! "video/x-raw,height=640,width=480,framerate=30/1" ! ximagesink` you'll get the raw output - this needs a GUI for the ximagesink, I seem to recall you can encourage fbdevsink to jam the video straight onto the screen even from the terminal but i've ...


1

MKV is just another container format. If it contains H.264 you can unwrap it and repack it into MPEG-4 using ffmpeg. ​ffmpeg -i vid.mkv -c copy -bsf:a aac_adtstoasc vid.mp4


1

You need to install the debian-keyring. Then replace the key 1F41B907 in both placed below with the key that shows up after the "NO PUBLIC KEY" from the end of the update list. I'm still getting a package error but I think it is just an error in my /etc/apt/sources.list: sudo apt-get install debian-keyring gpg --keyserver pgp.mit.edu --recv-keys 1F41B907 ...


Only top voted, non community-wiki answers of a minimum length are eligible