Hot answers tagged

3

There is nothing in HAT requirements about supplying a machine-readable list of sensors. Therefore, there is no generic methods to list sensors on a HAT: even if such a method exists, it will be manufacturer-specific at best and HAT-unique at worst. HAT EEPROM contains either a device tree overlay or a name of such overlay in an external file. See if ...


3

I'm using Ubuntu Server 20.04 LTS. The dtparams setting does not work, instead you need a udev rule. The fan config is in /sys/class/thermal/cooling_device0/, if you cat /sys/class/thermal/cooling_device0/type, it should be "rpi-poe-fan". Once you've confirmed that, use this udev rule as an example: SUBSYSTEM=="thermal" KERNEL=="...


2

Answer Remark: Just a quick and dirty answer. Perhaps more details later. Warning: no guarantee no nothing won't meltdown or blow up. I skimmed the datasheets and quickly concluded that there is 80% chance OK, for the following reasons: (1) Touch display is SPI, and relay is I2C, (2) I2C relay has well documented instructions to change ...


2

I wanted to know if it's possible to stack the hats Depends on the HAT - the Sense HAT exposes pins BUT putting another HAT on top would make it unusable. Some have stackable headers but not all. The Pi exposes GPIO 0-27, of which 0,1 are reserved - leaving 26. The Sense HAT uses some of the pins https://pinout.xyz/pinout/sense_hat so not all are ...


2

I wasn't able to get the ports each HAT will be using for the ReSpeaker 4-Mic Array and the 12-Bit/8-Channel ADC HAT. But I'm pretty sure you won't be able to do so because of an overlap in the pins the HATs will be using.


2

That is a servo and is controlled as other hobby servos. I.e. 50 Hz pulses in the range 1000 to 2000 microseconds long. The code will look the same.


1

Okay, I found a workaround solution for this issue. On the ClusterHAT 2.3 the I2C Expander is powered by 3.3V GPIO pin. This is powered off on reboot and resets the power states of the Pi Zeros. There is no real fix, but a workaround: Set the following properties in firmware WAKE_ON_GPIO=1 POWER_OFF_ON_HALT=0 Sources: this and that Enable sdhci quirks mode ...


1

Answer I tried the following: Inserted first SIM7600 HAT to Rpi4B and tested basic things OK, using Rpi on board TxD, RxD pins. Repeated 1. with second SIM7600 HAT. Tested two HATs at the same time, one inserted to Rpi, using TxD, RxD pins, the other using USB/TTL cable. Tested both HATs at the same time, each with a separate USB/TTL cable. In other ...


1

This post is full of mis-information. There should NOT be a line "console=ttyAMA0,115200" You should't have to disable Bluetooth, but if you must do it properly. There are no differences in default serial (or any of the GPIO functions) between Pi4 and earlier 40 pin models with WiFi. Downloading random software is risky - it is difficult to see what it ...


1

/dev/ttyUSB3 is likely busy because it is used by pppd. Run  lsof /dev/ttyUSB3 to confirm. If you need to send AT commands while using the PPP connection (typically, as a part of the startup sequence), you should add those commands to pppd configuration scripts (located in /etc/ppp/chatscripts/ if memory serves). If you want to test various AT commands ...


1

I have the same product. If you haven't yet found out it is /dev/ttyUSB2 port almost certainly based on your screen shot. Try apt install minicom. And start it with sudo minicom -s. Go to 'serial port setup'. Change selection labeled A to /dev/ttyUSB2 and change selection F to no. Hit enter next, with 'Change ...' field blank and you back one menu. Save as '...


1

Yes it's possible. The headers on the POE hat are passthrough style, but the pins on the Pi are too short to pass through them, so you need to extend the Pi's GPIO header, in turn this means you also need to extend the Pi's POE header. Various vendors sell kits for doing this, for example https://thepihut.com/products/4-40-pin-pin-extra-tall-header-push-fit-...


1

I just installed the same HAT on my Pi. Incidentally I had the same "issue". Is your user part of the audio group? Try: sudo aplay -l If that works, add your user to the audio group: sudo adduser username audio


1

In case anyone has also issues. The link to the raspberry pi forum helped me. Following steps are working for me. #install the packages sudo apt-get update && sudo apt-get install libqmi-utils udhcpc ifconfig wwan0 down # Enable OS Raw IP Mode setting (not persistent) echo Y > /sys/class/net/wwan0/qmi/raw_ip ifconfig wwan0 up qmicli -d /dev/cdc-...


1

First you have to press the pwrkey for around 3 seconds. Then wait for the Net LED to turn on (it can take up to around 15s). If there is a network, it should start slowly blinking after another 3-10 Seconds. Then try to run the command again.


Only top voted, non community-wiki answers of a minimum length are eligible