We’re rewarding the question askers & reputations are being recalculated! Read more.

Hot answers tagged

5

Just from the installation with sudo apt install hostapd there is nothing configured for the service. hostapd has no default setup so it doesn't make sense to start the service without it. To avoid possible confusion I suppose the package manager has decided to mask the service on installation. Just disable it is not enough to be on the save side because a ...


4

TL;DR use hw_mode=a I see that the man pages for hostapd are quite useless I found a more useful page https://wiki.gentoo.org/wiki/Hostapd with the following example 802.11a/n/ac with WPA2-PSK and CCMP A simple but secure AP for recent hardware: FILE /etc/hostapd/hostapd.conf interface=wlan0 # the interface used by the AP hw_mode=a ...


3

There are many quirks with creating the virtual interface ap0. You have to follow exactly a sequence, otherwise it won't work. If other applications bind to the wifi port it cannot be set. create a virtual interface ap0 for the access point start access point daemon hostapd using interface ap0 start wpa_supplicant for wifi client using interface wlan0 Many ...


3

The Tutorial you used is not up to date as it was written in 2013 and seems to be written for normal Ubuntu not Ubuntu Core. I never used Ubuntu Core but they seem to use systemd-networkd: By default network management on Ubuntu Core is handled by systemd's networkd and netplan. While NetworkManager has some support to handle netplan configuration ...


3

You have to do three steps: create a virtual interface ap0 for the access point start access point daemon hostapd using interface ap0 start wpa_supplicant for wifi client using interface wlan0 You have to do it exactly in this order otherwise the setup will fail. I have seen many attempts to achieve this including restarting services in order with special ...


2

I was redirected here from the excellent thread of Ingo because I'm trying to make my RPi3 to act as WiFi extender. Like you, I followed every steps and I noticed that a device connected to the extended WiFi network couldn't get any DNS address from the primary Wireless router. Something draws my attention on Troubleshooting section. @Ingo explains that ...


2

Compared to the official guidelines you are missing a) an entry to the file /etc/default/hostapd: DAEMON_CONF="/etc/hostapd/hostapd.conf" b) an entry to the file dhcpcd.conf nohook wpa_supplicant


2

I've resolved by myself, I have made a script in bash that restart the hostapd service with #!/bin/bash service hostapd restart and make it executable with sudo chmod +x /location/file then used sudo visudo and make the file executable without asking for password, adding in the file [your_username] ALL= NOPASSWD: /location/of/file went in ...


2

You also asked: "Maybe you got even hints for a better solution in general." I prefer to use systemd-networkd because it has all in one. Using two USB/wifi dongle simplifies it a lot. So my hint is to look at Access point as WiFi repeater with additional WiFi-dongle. It does not fit exactly your needs but it should not be a big problem to adapt it to your ...


2

You have configured a bridge with slave interfaces eth0 and wlan0. Everything looks good. You only have one (virtual) interface br0 with an ip address 192.168.1.90. Don't be confused by eth0 and wlan0. As slaves of the bridge they have lost their normal IP characteristics and only work on the OSI data link layer with MAC addresses. The normal interface of ...


2

The solution passed to remove the service file in /etc/systemd/system/hostapd.service. Using cat in this file, because nano wasn't able to open it, I saw that the file was corrupted, so I delete the file and now, I am able to start/stop the service, and everything related. Thank you to the ones that have tried to help me!


1

From Reddit, one of the users told me how to solve this problem: Ah, ok - that's looking better. It does remind me that the tutorial is a bit old and Tor keeps changing configuration options. You'll notice in the log that it's ignoring the TransListenAddress and DNSListenAddress entries. This used to force the whole thing to break but it's been a little odd ...


1

It turns out this was happening because I was trying to use the same wifi card as both a client and an access point. It was connecting to the WLAN network on channel 100, so depsite the hostapd settings, the AP could only operate on channel 100. I changed my wpa_supplicant settings (using the freq_list parameter) to force wpa_supplicant to connect via 2.4GHz....


1

I suppose your internet router is using a 5 GHz band. As @jake already noted in his comment there is a limitation of the wifi device on the RasPi. In my tutorial you have used, you will find in section ♦ Details - hostapd (Step 2): Please set the channel to the same value than wlan0 is connected to the wifi from your router. It is the restriction from the ...


1

After reading up on the concepts discussed in Ingo's replies I realised my (admittedly stupid) mistake! I had the device configured as a bridge, meaning that the the Pi itself wasn't assigning IP address's to the connected devices, simply providing an interface between the connected devices and the router! The solution involved a combinational approach of ...


1

My first guess was that the TP-Link Archer T2U wifi dongle does not support an access point but with your update you show that it does with mode AP. Another possible problem could be the driver for the USB/wifi dongle. You wrote that hostapd didn't recognized the driver. Seems hostapd now starts with its default driver but that does not fit to the dongle. ...


1

The important messages seem to be: nl80211: Set mode ifindex 3 iftype 3 (AP) nl80211: Failed to set interface 3 to mode 3: -95 (Operation not supported) nl80211: Interface mode change to 3 from 0 failed nl80211: Could not configure driver mode For my interpretation hostapd tries to set the interface to mode 3 (AP) that is an access point (line 1). But the ...


1

I reinstalled everything from scratch, now it seems to work... I noticed that the openvpn client does some interference during startup..


1

Did you update your Pi? If not run sudo apt-get update && upgrade, you Pi needs to update once in a while, it happends to me if I do not update it, and if that does not fix it run, sudo apt-get update --fix-missing


1

What is a IMX7 device? Is it a Raspberry Pi? The tutorial you have linked to is made for a Raspberry Pi with extensive using systemd-networkd and its dependency management. Look at the Details - General section. There are three steps that must always be done in a strict order. I suppose connman (you don't gave a link) is one of the scripts that automated ...


1

To have the access point and the ethernet port using the same ip address range, means using the same subnet, you have to setup a bridge br0 and then add as members the interfaces eth0 and wlan0. Because you are already use hostapd and dnsmasq you may have a look at Setting up a Raspberry Pi as an access point in a standalone network (NAT) how to do it with ...


1

This issue comes from kernel and hostapd service in raspbian jessie. In your logs in 385 line you can notice that 4-way handshake has never ending and it stoped on third step. It could be exception in pseudorandom generator. You can use external WiFi dongle as a workaround now, or wait for a patch.


1

ENABLE SSH SSH is what you're looking for. If you connect your RPI ethernet port to your router you can use arp -a (linux, mac) to see all IP addresses on your network. You will likely see your pi as pi (192.168.1.15) or something along those lines. Once you find the pi IP you can connect to the raspberry pi using the ssh command. When connecting to the ...


1

As far as I see you only want to setup a stand alone access point but there are some things mixed up. First you are using deprecated commands ifconfig and iwconfig. You should use its modern successors ip from iproute2 and iw. Everywhere you are using sleeps. When nothing works a sleep mostly helps but it indicates that there is something wrong with service ...


1

Please take note that using /etc/rc.local has limitations due to Compatibility with SysV. Following the recommendation of the developers from systemd you should avoid using rc.local. In addition your script is doing things that assumes that hostapd is up and running. That may or may not be possible because there is no dependency to start your script After=...


1

You need to check the sections IEEE 802.11n related configuration (IEEE 802.11n in the 2.4GHz band is available e.g. with the built-in Wifi chip of the Raspberry Pi 3B) and IEEE 802.11ac related configuration in case your wifi chip is capable of IEEE802.11ac (as is the built-in wifi chip of the Raspberry Pi 3B+). The comments in the config file already give ...


1

Try starting with channel=48 and without using acs_survey. Once you get something working you can experiment from there.


Only top voted, non community-wiki answers of a minimum length are eligible