New answers tagged

0

SOLVED: The problem I made was there because I was mounting and chroot-ing into the image using qemu, and changing the /etc/wpa_supplicant/wpa_supplicant.conf file directly, and for some strange reason that file was not being read or whatever by system and rfkill blocked wlan0 because contry was not set. What I did is let the system update wpa_supplicant....


2

I prefer to use systemd-networkd so I can only help with Setting up a Raspberry Pi as an access point - the easy way and I haven't used EAP authentication so far in my home network. Have a look at the examples at the end of /usr/share/doc/wpa_supplicant/examples/wpa_supplicant.conf. Purging rfkill is not the right solution. rfkill unblock wlan will ...


0

Use /etc/network/interfaces for wlan config and disable dhcpcd. Hostapd working on Pi Zero W on stretch-lite and buster-lite! Many posts talk about driver issues and most recent posts leave /etc/network/interfaces unchanged. Comments in this post have it right. Thank you!!


Top 50 recent answers are included