Hot answers tagged

2

As a side note to anyone experimenting with the i2c baudrate, you don't have to set the baudrate via config.txt, which requires a reboot. You can do it at runtime by configuring the kernel module with modprobe: sudo rmmod i2c_bcm2708 sudo modprobe i2c_bcm2708 baudrate=400000 Also bear in mind that Pi does not support clock stretching on I2C, so I2C devices ...


1

Most of what you have configured is not needed and may be part of the problem. Don't add modules to /etc/modules, don't set the GPIO mode with raspi-gpio or similar, don't enable automatic load of I2C kernel at boot. Remove everything you have done and just add the following line to /boot/config.txt. dtparam=i2c_arm=on Reboot and check that the device /dev/...


1

Yes, set the GPIO back into mode ALT0 (needed by GPIO 2/3 to be in I2C mode). Tiny GPIO has the following define to use to set that mode. #define PI_ALT0 4


Only top voted, non community-wiki answers of a minimum length are eligible