New answers tagged

0

The issue got resolved. The default setting of buildroot did not enable the following configuration: BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_MDEV=y This was causing the spidev modules to not load, even when they were built in the kernel. After adding the above configuration and rebuilding the kernel, the /dev/spidev0.x and /dev/spidev1.x appeared. I got help ...


1

You might want to consider using the "official" documentation rather than documentation derived from the official docs. I don't know much about building kernels, but the rpi-update utility may serve your purposes as well as building the kernel yourself.


0

I had been adding a device tree overlay for the iio adxl372 device driver. This added it to sysfs, but meant that the driver took ownership of the spidev. Removing the dtree overlay fixed the problem


1

By default, Raspberry Pi installations do not normally enable the SPI functions. Without SPI being enabled, the /dev/spidev0.0 inode is not created. This procedure is taken from https://pimylifeup.com/raspberry-pi-spi/, to which all credit is due. The procedure outlined above uses the raspi-config tool to enable SPI. In case the link breaks, I've summarized ...


1

If you use the mainline kernel, you will miss all the Pi-specific patches which fix the issues unique for the Pi hardware. Some devices may not be initialized properly, or you may experience quirks if you try to use them. You may also have to include all VideoCore-related steps in your build process, which is of no interest to Linux in general since ...


0

When you compile the linux kernel for an specific platform, you must provide the architecture configuration (or configure entirely by yourself), located at arch/<architecture_name>/configs. Providing this configuration, the kernel will be preconfigured for an specific board (eg. arm/imx_v6_v7_defconfig) and it will be faster and easier to compile the ...


1

Encountered the same kernel panic error on my 0W, also while doing an apt-upgrade but I suspect its just the amount of network traffic generated by apt-upgrade that causes it, not apt. This occurs from a fresh Raspbian install, both lite and full desktop versions. I had to disable IPv6 by adding "ipv6.disable=1" to the end of /boot/cmdline.txt . ...


Top 50 recent answers are included