Hot answers tagged

55

If you want to login as root using SSH or WinSCP you need to edit the config of SSHD, do this: Login, and edit this file: sudo nano /etc/ssh/sshd_config Find this line: PermitRootLogin without-password Edit: PermitRootLogin yes Close and save file reboot or restart sshd service using: /etc/init.d/ssh restart Set a root password if there isn't one already: ...


22

Enter the command sudo raspi-config. Scroll down to Boot Options and select Console Autologin. Then exit the configuration menu and reboot.


19

The username is "pi" and the password is "raspberry", you have misspelled the word "raspberry" by missing the p. If you still have issues, I would try re-downloading, re-formatting, and doing it once more. I think you'll be fine after correcting the password entry. It's good practice after logging in to change the password of the user from the default. ...


18

It looks like your X server is working fine, but either your login manager or your desktop environment are failing to run properly (the former is supposed to ask for a password, then start the latter for you). How to investigate Since you can login via command line, you can easily access important log files which you should check for error messages. Login ...


14

Defaults are Username: root Password: centos


12

This can easily be done with raspi-config. Run the command sudo raspi-config Select Boot Options Choose Desktop Exit the prompt and restart the RPi Edit: To address you wanting to do this from the command line for a bash script, I suggest we look at the actual source of raspi-config (which is written in bash). if [ $SYSTEMD -eq 1 ]; then systemctl set-...


9

This is, as mentioned, the contents of the /etc/motd file. The actual file shown (/run/motd.dynamic) is constructed using the scripts in /etc/update-motd.d and the file /etc/motd. So for static content you can modify /etc/motd but if you want to generate dynamic content then you should add scripts to the /etc/update-motd.d directory.


8

Autologin is performed as part of systemd's getty target: root@raspberrypi:/etc/systemd/system/getty.target.wants# ls -l total 0 lrwxrwxrwx 1 root root 38 Sep 24 18:14 getty@tty1.service -> /etc/systemd/system/autologin@.service The raspi-config simply manipulates this symlink. To switch to manual login, execute (as root): ln -fs /lib/systemd/system/...


6

You cannot login as root because Raspbian does not have a root password. See Raspbian root default password Normally ssh does not allow root access because this is considered a security risk. You should be able to do everything you need using sudo (which is the normal Debian practice). If you REALLY want ssh root access it can be enabled.


6

You could configure the RPi to auto-login as the pi user. You can configure this via sudo raspi-config. To do the same thing manually, create a file /etc/systemd/system/getty@tty1.service.d/autologin.conf containing: [Service] ExecStart= ExecStart=-/sbin/agetty --autologin pi --noclear %I $TERM replace pi with the desired existing user account. I have ...


5

MariusMatutiaes accepted answer worked for Raspbian Jessie (March 2016) too: Edit the file /lib/systemd/system/getty@.service and change the line ExecStart=-/sbin/agetty --noclear %I $TERM to ExecStart=-/sbin/getty/ --noclear -a root %I $TERM Reference: https://superuser.com/a/970013


5

That file is not on rpi 3 you are trying to connect to, but on the computer where you are trying to connect from (Ubuntu?). Just run ssh-keygen -f "/root/.ssh/known_hosts" -R 192.168.1.234 on your computer. Not on the rpi.


4

As far as I know there's no way to boot into runlevel 1 on the pi without configuring it to do so first, which is not really an option at this point. That line applies to runlevels 2, 3, 4, and 5; the original default is 2, and that's what you are getting. The only thing you can do is take the card out and fix inittab. If you can't access the second ...


4

I'm not sure why you would want to autologin as root, but if its just for the sake of saving those few seconds you can choose to auto login with the pi username in the raspi-config settings:


4

I got the exact same problem just now. It seems to relate to .Xauthority file. I just removed this file in the home folder by: sudo rm /home/pi/.Xauthority Now it's back to normal


4

Jesse Lite does not include the GUI it is just the core OS. Thus when you put in your username and password you get the terminal. This is very useful for headless servers that you can communicate with SSH. Or you can hook a display up to it and use it that way. Advantages... Lower performance overhead, and uses less disk space. and if configured correctly ...


4

USB is not a symmetrical protocol, meaning, it is not peer to peer the way, e.g., IP networking is (it might be considered to resemble higher level client-server network protocols). A USB hub/controller (they are internal) and the ports connected to it (the jacks you see) are either masters (aka. hosts) or slaves (aka. clients). A slave connects to a ...


4

You can configure your system to automatically log into the command line by creating a file in /etc/systemd/system/getty@tty1.service.d/override.conf with the following content: [Service] ExecStart= ExecStart=-/sbin/agetty --autologin yourname --noclear %I $TERM You will need RW access to the filesystem. If you can't log into the RPi directly, you can ...


4

That is the "Message of the Day" or "motd" you can find it in /etc/motd sudo nano /etc/motd


4

To have a decent answer, here is it what the questioner posted in a comment: I've resolved the problem by mounting the SD card on another computer, mounting the root filesystem, and deleting the contents of the password field in /etc/shadow. Still, I'm curious to know how to enter non-typeable characters at the console (how to type "#" with the ...


3

Assuming you are using Raspbian, you can use raspi-config to delay boot until the network is up. start raspi-config with the following: sudo raspi-config then select option 4 Wait for network at boot then select Slow Wait for network connection before completing boot click Ok Then Finish Finally reboot.


3

Not enough reputation to comment, but the little rainbow in the corner is the pi telling you it doesn't have enough power. Check / change your power supply. Not sure if that will solve the problem, but it will at least avoid another one. See here for information on the warnings.


3

In the article, one of the things mentioned is disabling password login: PasswordAuthentication no Commenting the line or changing the value to yes permits password login again.


3

It's already working since you can connect to it. Putty would give a connection refused error otherwise. In this case, make sure you typed the password correctly. If you did not change it, the password should be raspberry. Another possibility would be you're connected to the wrong machine.


3

just faced the same problem. everything written before is right, BUT : my installation had an english keyboard layout, which means, to input my "raspberry" pw i had to press "raspberrz"


3

So, here's what I learned... sshd is enabled by default. The default login credentials of raspberry/raspberry, given in the FreeBSD Foundation HowTo, appear to have changed. It the install instructions on the FreeBSD wiki an update from 2015-06-26 shows the default login and password as freebsd and freebsd. The default root password is listed there as root.


3

The Raspberry Pi OS uses systemd, so you will find logs in its journal. It also contains the logging from the OpenVPN server. Look at it to the current boot with: rpi ~$ journalctl --boot=0 --pager-end You can filter it to the service: rpi ~$ journalctl --boot=0 --unit=openvpn.service


2

cut -d: -f1 /etc/passwd will list all users. To Change Password sudo su [USER] and then you could use raspi-config to change the password, as it does not require the current password to be entered.


2

Libtinfo is an ncurses library; bash uses this to get information about the terminal it is in in order to implement certain features correctly. It is a fairly fundamental thing since the default shell (bash) requires it. Installing some package would never cause this library to be removed, so something stranger than that has happened. It could be that the ...


2

I had same problem and I discovered that the issue was because my password have special characters and the default keyboard layout is English(UK), so when I thought I'm typing @ I really is typing ". I changed the keyboard layout to English(US) using raspi-config and changed the password after that, and it worked perfectly. Hope it helps.


Only top voted, non community-wiki answers of a minimum length are eligible