Hot answers tagged

8

I faced the same issue with Raspberry Pi 4 and Raspbian Buster, the solution for me was to modify the following file: /lib/systemd/system/systemd-udevd.service Before: PrivateMounts=yes After: PrivateMounts=no Then I rebooted and it was OK ;)


4

Because Raspbian is based on Debian, I suggest you to create a permanent system-specific configuration file according to the definitions as given in Debian's policies (see https://www.debian.org/doc/debian-policy/ch-files.html#configuration-files). Buster has a solid configuration for systemd and udev placed in the package's library files at /lib/systemd/...


4

I don't think the Pi model is a factor here. When you made your backup, did you select New partition UUIDs? If not, that's likely the problem. SD Card Copier help says this: Under Raspbian Stretch and later versions, you cannot mount two partitions with the same UUID, so you will not be able to mount a cloned SD card when booted from the disk from which ...


3

How do I manage to get the variables $bootstrt $offstcorrect? You do not need them. You should losetup give a try. It is for beginners and will mount your images automagically. You do not have to fiddle with error prone offsets and it will simplify your script very much. For example I have used the Raspbian Buster Lite image: pc ~$ sudo losetup --find --...


3

I see what looks like two mounted drives Actually what you see are two directories -- that may be used as mount points, but then, pretty much any directory can be used as a mount point. The ones in /media are conventionally used for fuse automounts (ie., those for non-privilleged users). Try mount | grep pi/media and see how many lines of output there are....


3

Try the usbmount package. sudo apt-get install usbmount Read about it at: https://www.raspberrypi.org/forums/viewtopic.php?t=205016 Worked for me. Regards, Jon G


3

using /etc/fstab is the proper way of doing this. if you do not want your system to depend on the drive on startup in case the usb drive is missing you have to set the relevant parameter / options from man fstab nofail do not report errors for this device if it does not exist. so your fstab should have an entry like this:...


2

Very late response but I came across this while searching for an answer myself. I solved this problem by setting deluge to download to a local directory on the Pi first, then use the "move on completed" option in deluge to move the completed file to your mounted curlftpfs directory. It will successfully seed as well. Hope this helps someone who ends up here ...


2

Please use Greg's solution. I don't know if mods wish to remove this SO.... I am currently using pmount. Removed USBMOUNT and installed it using the instructions here: https://raspberrypi.stackexchange.com/a/66324/68240 "thanks to the original author btw" The only extra was that I had to sudo chmod +x /usr/local/bin/cpmount Since it was not working at ...


2

If it works when you mount it manually you are probably missing the auto flag in the fstab configuration. You should also use UUID instead of the device name (eg. /dev/sdb1). This way you won't have problems when using more than one USB drive. (comment - Can't check any of this because you didn't include the line you've entered in fstab)


2

I have solved the issue described. The /media/pi folder was owned by root, so presumably subfolders could not be created. I did: sudo chown -R pi:pi /media/pi and all works correctly.


2

I just have tried to write to an encrypted volume: TrueCrypt, AES encryption, the container is a partition on a USB3 drive, encrypted drive formatted as EXT4. I see a data rates between 45 and 52 MB/s (according to my file manager), with CPU load hovering around 65%: about 30% used by TrueCrypt and another 30% used by USB XHCI driver. My TrueCrypt ...


2

I know you are trying to replace an automount. fstab is confusing, the documentation for mount is somewhat clearer. If you are happy with the way automount works I suggest you let your system automount, then issue the mount command and copy the settings. The following is a line from my fstab. I use noauto and manually mount, but if you want to mount on ...


2

This is the line in my /etc/fstab for a Toshiba Canvio 1 TB usb drive. Your UUID and mount points will be different. UUID=A0027BBF027B994C /media/pi/Toshiba ntfs-3g defaults,auto,umask=000,users,rw,nofail 0 0


2

You DO NOT have 2 drives, you probably have 2 mount points, one of which may have a drive mounted on it. The automount "feature" creates mount points, and can create many if drives are re-attached without properly unmounting - there are many reasons this can occur. If you attempt to write, without checking that a drive is mounted, you will write to the ...


1

If the drive does not have a separate power supply, check sudo grep "Under-voltage" /var/log/syslog for clues that this is an issue. You could try fiddling with the drive parameters using hdparm (pretty sure that's the name of the package if it isn't installed). From man hdparm: -B Get/set Advanced Power Management feature, if the drive supports it....


1

As I understand your situation: You have a NAS drive mounted on your RPi. Let's assume that mount point is: /mnt/wdmycloud/raspi You also mount a thumb drive on your RPi. Let's assume that mount point is: /mnt/thumbdrv You have a script called rsnapshot that you have scheduled to run at regular intervals in a cron job. rsnapshot copies or backs up some ...


1

The permissions of a NFS mount is determined by its export on the NFS server. You should check its setting in /etc/exports on the NFS server. There are many options to define the permissions; just to point you in the right direction because it is out of scope here on Raspberry Pi.


1

How do I manage to get the variables $bootstrt $offstcorrect? IMHO, Your initial approach is good. I would just avoid using an hardcoded value for the sector size, just in case of ... You maybe could use sfdisk instead of fdisk: it has been developped to ease scripting. Oh, and: To do arithmetic with bash, use the syntax offst=$((bootstrt*512)) (aka double-...


1

I use the following to periodically Backup SD Card This uses losetup to mount a remote image and rsync to update the backup. My script is based on backup tool, although this has since changed. It is relatively simple to loop mount a partition in an image. The package includes an image-mount utility which can be used to mount images on the Pi (or any Linux ...


1

To automount your USB drives to a directory of your choosing: In accordance w/ man fstab: The second field (fs_file). This field describes the mount point (target) for the filesystem. For swap partitions, this field should be specified as none. If the name of the mount point contains spaces these can be escaped as \...


1

any changes to this file are lost when I remove the SD card This may be a sign of your SD card reaching end of life. Well-behaved cards become read-only when this happens, so that you can recover the data that's already on them, instead of trashing that data with failed write operations. If you are absolutely positive you can't write to the SD card any ...


1

The error message says it all: Volume was not properly unmounted. Some data may be corrupt. Please run fsck. Go ahead and run sudo fsck -a /dev/sdb1. Another option is to plug the thumb drive in a Windows PC and go to Drive context menu -> Properties -> Tools -> Check.


1

You mount the filesystem with ntfs. This driver provides only read-only access according to Debian NTFS. You have to install the third generation NTFS device driver with: rpi ~$ sudo apt install ntfs-3g and then mount your filesystem with FSTYPE ntfs-3g. Then you have read/write access to your mounted device.


1

The fstab was correct but the UUID was wrong. It was mounting in the gui because auto mount was on. Not because of the fstab.


1

There is not very much information you have given about error- and debug-messages. Look at the journal if you can find some messages belonging to mounting network shares: rpi ~$ journalctl --boot --pager-end What message do you get with rpi ~$ sudo mount 10.0.1.6:/c/media /mnt/nfs Try with verbose output rpi ~$ sudo mount --verbose 10.0.1.6:/c/media /...


1

Well, I feel slightly stupid: the Pi had some uptime and turns out the kernel had been updated, but the modules would not fit unless I reboot. After a reboot cifs would work just fine.


1

The same error is thrown when you want to issue raspi-config -> Expand Filesystem after resizing the RaspberryPi image physically with qemu-img resize raspbian.img +6G and booting on Qemu. Here is how you can workaround it: Boot your RPi and issue the following command: sed -E 's/mmcblk0p?/sda/' /usr/bin/raspi-config | sudo bash Select (7) Advanced ...


1

yes you can mount the fat partition for temporarly reasons, otherwise use fstab sudo mount -t vfat -o uid=root /dev/mmcblk0p1 /mnt sudo nano /mnt/cmdline.txt have fun


1

I suspect the problem might be custom VID/PID assigned to the device preventing the default FTDI driver module from being associated with the device correctly. As far as I know there are two ways of telling the module about the new VID/PID (other than recompiling it): Running modprobe in a udev rule to pass the extra parameters to the module: ...RUN+="/sbin/...


Only top voted, non community-wiki answers of a minimum length are eligible