Hot answers tagged

9

HOW TO REPLACE SSH HOST KEYS ON RASPBIAN W/O BOOTING INTO IT Note: I had this happen with a recent download and install of Raspian full... it occurred on a headless pi zero W and a headless pi 3B+. This solved it in both cases. Not sure what was wrong with the keys but I suspect something may have been broken in the distribution. If your ssh "connection ...


7

Same issue with both stretch and jessie. Until you enable the service with: systemctl enable ssh you cannot refer to the service as "sshd". Once the service is enabled, no problem, you can even disable the service with: systemctl disable sshd Really stupid in my opinion but that's the way it is.


5

If you are looking for a procedure to change the SSH default port to another port number like 2222, check the SSH config file which is located on /etc/ssh/sshd_config. sudo nano /etc/ssh/sshd_config So, you would see Port 22 that you can change it to Port 2222. Then, save the file and restart the SSH service: sudo service ssh restart


4

First, if you have a spare Raspberry, you should set it up as similar as possible to the ones you have remote and use it to test until you have it working, while you can see error messages and refine your process. If your file system is read only, you don't have to worry about corruption be writes from the running system. You don't just need dd and reboot, ...


4

In my case on raspberry pi 3B+ device with raspbian OS work this: sudo service ssh status sudo service ssh restart


3

As stated in the comments the main service is ssh.service. But you can it also address with sshd.service. As you can see ssh.service has an Alias: pi ~$ systemctl cat ssh # /lib/systemd/system/ssh.service [..] [Install] WantedBy=multi-user.target Alias=sshd.service pi ~$ Quoted from man systemd.unit: In addition, unit files may specify aliases through ...


2

You can easily program your Raspberry Pi Zero W via SSH. Should be configured Wi-Fi connection and SSH to be enabled. Follow the next steps: Go to Raspiconfig, just type in terminal: sudo raspi-config choose Interfacing Options and set SSH enable. This will help to connect to Raspberry Pi via SSH. After that, go back and go to Network Options and choose ...


1

EDIT: This only seemed to fix the problem temporarily! FOUND THE SOLUTION! It seems it was an issue with the router. My DHCP IP range was set to be 10.0.1.100-10.0.1.200. This seemed to cause an issue with how the router handled the traffic between devices and would drop connections. I set the DHCP range to 10.0.1.2-10.0.1.202 and it seems to work fine now....


1

Using Ingo's answer I determined that it was unable to bind to the local address I had specified; so when I figured that out I went into my Unit File (/etc/systemd/system/sshd.service) and added the following two lines: ExecStartPre=/sbin/ifconfig -a ExecStartPre=/sbin/ip addr The on the next reboot, the -ddd output from adding this allowed me to determine ...


1

You can set the debug output on the sshd daemon. Edit /etc/default/ssh and set the option to: SSHD_OPTS=-ddd Then restart the raspi and look at the journal. Here is an example of a successful startup on my RasPi: rpi ~$ journalctl --unit=ssh.service Mar 24 11:08:47 raspberrypi systemd[1]: Starting OpenBSD Secure Shell server... Mar 24 11:08:47 raspberrypi ...


1

With specific services like tftp you can use port forwarding on the Raspberry Pi to forward the network traffic to the MS Windows computer. For my example I will use interface eth0. Just change it if you use another interface, e.g. wlan0. Then ensure from the RasPi that you can ping all involved devices. I will use these names: rpi ~$ ping client rpi ~$ ...


1

I ran into the same situation today Although it is already 7 months from @Kevin's question this is how I solved it. Once you have your Ubuntu (20.04 in my case) installation ready in your USB, edit the user-data file Under the section ## Install additional packages on first boot, Uncomment packages, and add a new entry for the openssh-server package. For ...


1

You can easily program a Raspberry Pi over SSH. I guess you've already seen in headless setups how to configure your RPi to connect to your WiFi network and enable SSH. If not, here is a quick how-to: Setup headless RPi Add an empty ssh file in /boot/ directory Inside the rootfs partition, edit the /etc/wpa_supplicant/wpa_supplicant.conf file so that it ...


1

This can happen when you have ssh'ed into a pi, then created a new filesystem (FS) (new sd flashed), and then attempt to ssh in again because the host keys are now different than what has been stored into your known_hosts. Thus, your host that you are attempting to ssh from notes that the host keys of the Pi have changed and correctly sees this as a ...


1

one method of doing this is by running: source ~/.profile workon cv


1

This can happen when you put the activation code for virtualenvwrapper in the wrong bash startup script. ~/.profile is not run on a non-login shell (like the terminal started in the GUI). It is run if you log in using SSH. To have it activated in both situations you can move the code over to ~/.bashrc NB: the code you have to move looks something like this....


1

Try upgrading the distribution instead, not sure if SSH is included in that, it might be apt-get dis-upgrade or if you're using OpenSSH target the app apt-get update openssh-server If you need to see whats installed use this, dpkg --get-selections if you see anything with SSH in, you could try an upgrade or update with the package name displayed in ...


Only top voted, non community-wiki answers of a minimum length are eligible