New answers tagged

3

If you typed sudo passwd without any other arguments, you changed the password of the root user. If you want to change the password of a regular user (for example pi), there are two easy ways to do it: Log in as the user and run passwd without sudo. Run sudo passwd pi to change pi's password. You can replace pi with any username that exists on your system. ...


1

It works fine when I create a key with PuTTYgen. So it works fine now. Thans for yours help, Nenad


1

As seen from the debug log there is an identity file /home/nedad/.ssh/id_ed25519-cert used for authentication. The log doesn't show that it is denied or accepted and have not finished messages. You should paste the complete log output to the question. B.t.w., using a private keyfile for authentication like you do, it is normal that it is protected with a ...


1

You should be able to set the PreferredAuthentications key in your servers (Pi) /etc/sshd/ssh_config by adding the line PreferredAuthentications publickey and then restarting the ssh-daemon (sudo systemctl restart sshd) or just rebooting. You could also try to log in with this option added to the ssh command and explicitly specifying the private keyfile (...


0

Installing desktop envirnonment will solve the problem To install XFCE, enter the following command: sudo apt install xfce4 xfce4-terminal


Top 50 recent answers are included