New answers tagged

0

This is very rough but a bit long for a comment so I understand if it gets voted down as an answer :-) I'm also unsure how the Tkinter processes may impact the threads below. Create a first in - first out queue (FIFO Queue) using the built in class. Create a thread using the built in class to monitor the serial port. Once it has valid data, store that value ...


0

Turns out the /boot file system was set to read-only in /etc/fstab. Changing that to rw did the trick. Of course, I have no idea how it wound up this way. proc /proc proc defaults 0 0 PARTUUID=9975ff21-01 /boot vfat defaults,ro 0 2 PARTUUID=9975ff21-02 / ext4 ...


1

easy option is to use cpu-frequtils sudo apt install cpu-frequtils With cpufreq-info you will get an info on what frequencies and governors are possible for your cpu. Then set the governor to powersave to have the cpu running at the lowest frequency all the time. (according to this governor description) sudo cpufreq-set -g powersave or if you wanna have ...


0

As you surmised the basic error appears to be Read-only file system. This is usually indicative of a damaged or worn out SD Card. Most of us would restore from a backup to a fresh SD Card.


0

got to Settings/interface, this is where it gets tricky. go to the bottom next to the settings cog and hit enter till it goes to expert then go to regional and change timezone country then do regular time zone


0

Whenever I tried accessing my Raspberry Pi 4B using VNC Viewer from my MacBook Pro I would get the "timed out" error whenever I typed "raspberrypi" in the connect field. Then I tried typing the IP address of my RPi instead and it worked perfectly. It asked for approval, user name and password. After that I was in and managed to work ...


0

There is an excellent answer for this at streamlit. It worked for me. Another forum member claimed it worked for them. It is a substantial build: disk space to build: ~ 5.6 GB for llvm, ~0.6 GB for arrow disk space of the install: ~ 0.7 GB Because I had installed some of the Python packages previously (Cython, most specifically) as the pi user, but not with ...


0

I tried putting a 5100 ohm resister (I didn't have a 4.7k handy) in series with my output pin but my buzzer module would still stay on constantly. After reading about it triggering on a low signal and being for an Arduino, I finally stumbled onto using 3.3V to power the module and setting the control pin output to LOW to turn it on and HIGH to turn it off. ...


0

Most routers recommend SSID consist of up to 32 alphanumeric characters, but there is nothing to prevent any string of zero to 32 octets (32 bytes) being used. Indeed iPhones typically use Unicode character U+2019 "single right quotation mark" in the SSID - which is legal, if very inconvenient. If you ACTUALLY setup the Pi networking following the ...


0

There are generally two common practices: Get a static IP/domain and make the raspberry appear as a server, so it "can be found on the internet". Then make the nodeMCU connect to this server and transmit data. Use Hole Punching techniques to avoid that the raspberry PI appears on the internet. In that case you still need a third server to exchange ...


0

I assume this happened because the SSID had emojis in its name, specifically a red heart. I replaced the heart emoji with an <3 in the name of the router Wifi and then the pi connected fine.


0

I was (finally) able to solve this... I thought the problem might be with my power supply because of that undervoltage warning, so I put a USB voltage/current meter on my power supply, and saw that it was only delivering 4.9 volts, so the undervoltage warning was legit. I got a better power supply, and that problem went away. But, this didn't change my ...


1

Use class 10 type (good quality) SD card and use this for flashing the image. Verify the version of Raspbian OS with RPi board revision and flash that OS.


0

if it really is cmake that it can't find: sudo apt-get install cmake But at that point it will probably complain that it can't find arrow (the C++ libraries). in which case, see: https://github.com/apache/arrow/blob/master/docs/source/developers/cpp/building.rst with the key parts (given Raspberry Pi): sudo apt-get install build-essential cmake git clone ...


0

I finally found the solution: Instead of using Ethernet, I connected the Raspberry Pi to my WiFi Network and apt update and apt upgrade runs smoothly. Do you have any explanation for this strange behavior? This is not the first Pi which I connected to my local network via Ethernet. Never had such problems before.


1

Try this: sudo apt clean sudo rm -rf /var/lib/apt/lists/* sudo apt clean sudo apt update sudo apt upgrade


1

You've broken something. What? No idea... you say you've Changed the /etc/apt/sources.list, but you didn't say what you began with, or what you have now. You should copy/backup the files you've created to a USB drive, download a fresh copy of RasPi OS, and re-flash your SD card.


2

You can purchase a cheap USB to TTL serial adapter and connect it to the pins 6, 8, and 10. With a serial terminal program you can use the debug console that is exactly the same console as used with ssh. For details you can look at What is the correct way to connect serial console on RPi4 Model B?.


1

There are several UARTs on the Raspberry Pi and at least 2 are connected to GPIO pins. So yes, you can connect one of the UARTs on the GPIO pins to the wifi access point. Just make sure that the wifi access point uses 3.3V levels and not 5V levels or you also need a level changer.


0

Use /etc/network/interfaces for wlan config and disable dhcpcd. Hostapd working on Pi Zero W on stretch-lite and buster-lite! Many posts talk about driver issues and most recent posts leave /etc/network/interfaces unchanged. Comments in this post have it right. Thank you!!


1

Try removing xserver-xorg-video-fbturbo, it causes this behavior as well as other problems: sudo apt-get remove xserver-xorg-video-fbturbo sudo reboot


2

I tried to do it via connecting to hotspot with no password but comes out that SSH is not enabled (I guess the issue is with firewall or sth). How I solved it was using the graphical package manager (Raspberry logo on upper left -> Preferences -> Add/Remove software) to install virtual keyboard and typing my wifi password. After that, the SSH worked ...


Top 50 recent answers are included