We’re rewarding the question askers & reputations are being recalculated! Read more.
4

adding an 'asymmetrical' ALSA device worked: change the contents of /etc/asound.conf and ~/.asoundrc to the following: pcm.!default { type asym playback.pcm "hw:0,0" capture.pcm "hw:1,1" } and sudo alsa force-reload for good measure


3

Configure looks for the presence of the development libraries of PulseAudio, Jack and ALSA, in that order. That is why in answers like this it is mentioned that "...It also appears that ALSA will not be used if PulseAudio is installed...". In my particular case, I didn't have anything else installed besides ALSA. But then I remembered that I did some tests ...


3

This site isn't made for "which works best for my requirements" as this is highly subjective and likely to change, but a couple of alternatives are: Volumio - mpd-based, web interface, supports queuing and has a browser interface RuneAudio - also mpd-based, web interface, based on same code as Volumio but with different features (I use this one) Both these ...


3

I found the solution for my problem and it's to remove --disallow-module-loading flag. It prevents loading of module-bluez5-device as this module is always loading on-demand and can't be pre-loaded on startup via defaults.pa/system.pa.


3

Pulseaudio is incredibly tedious. I think this has something to do with dbus. I've been sitting here for hours just to get it working somehow. Tried systemd units system-wide, systemd units in --user mode, … nothing worked. The only way I got this to work was: move away the provided autostart: mv /etc/xdg/autostart/pulseaudio.desktop /etc/xdg/...


3

I've got it working with a USB bluetooth dongle right now. Here's a general outline of what I did: Remove bluez 5 and pulseaudio with apt-get remove. Compile and install ALSA from source. Compile and install bluez 4.101 from source. Copy libasound_module_pcm_bluetooth.so to the folder: /usr/lib/arm-linux-gnueabihf/alsa-lib/ (used find -name to locate it) ...


3

This is a known bug on the rpi3. internal Wifi and internal Bluetooth simultaneous usage will provoke crackling sound and sound disapearance. No fixes yet. https://github.com/raspberrypi/linux/issues/1402 Using a bluetooth dongle or Wi-Fi dongle resolve the problem.


2

After much digging around and beating my head against the wall I finally got it working. I had to change /etc/pulse/default.pa where it mentioned Bluetooth to load-module module-bluetooth-policy load-module module-bluetooth-discover load-module module-switch-on-connect Then I had to plug in a monitor and keyboard and make sure it connected on the desktop, ...


2

layla writes on http://robot.laylamah.com/?p=35 Note, if you receive an error such as the following: Error opening audio device plughw:1,0 for capture: Connection refused Mixer load failed: Invalid argument FATAL_ERROR: "continuous.c", line 246: Failed to open audio device You likely have pulseaudio installed, which is causing sphinxbase to attempt to use ...


2

Okay, I've done some tests. Setup: Pi 3 without a heatsink, 1A power supply (artificial starvation, on purpose) Fresh install of Raspbian Jessie Lite (downloaded a few minutes ago as of writing) Samsung Galaxy S6 Duos VLC player for Andorid 320kbps HD copy of Tremor by Martin Garrix 320kbps HD full copy of Tomorrowland 2014 @ Belgium (57min:11sec) Modified ...


2

Use amixer -c2 controls to list all the low-level controls. Then you can use amixer -c2 cset .. to select specific controls by their unique ID number.


1

You may use the ALSA output to use the stereo jack /etc/mpd.conf audio_output { type "alsa" name "My ALSA Device" } Alternatively if you want to listen to music from your Android or IPhone or tablet you can setup the Streaming output. Then standard Apps can listen to your music from RPI by standard stream: /etc/mpd....


1

I was just running into this issue today. I had jackd, jackd2, and pulseaudio installed, and I couldn't get any decent playback of my sound files. I wasn't actually using any of those packages for playback, I was just attempting to use Alsa. After running: sudo apt-get remove jackd jackd2 pulseaudio I'm actually able to playback my files using certain ...


1

Try sox library, I don't find it necessary to implement your own fft code for that, sox has easy tool for stuff like this, here is the link. https://linux.die.net/man/1/sox you probably just need "silence" but try it with high threshold. If you want to use it in .py file you just need to import a sox implemented library like https://pypi.python.org/pypi/sox


1

You may have a problem that's unrelated to the fact that you're using a DAC, but with the radio webpage itself. This may be an easily fixable issue, however, I will offer a different approach: After inspecting the webpage source, I noticed that the radio stream it plays is at th following URL: http://audio.scdn.arkena.com/11016/fip-midfi128.mp3. You can ...


1

I got pulseaudio 7 running on my raspberry jessie. I used this post, in DEBIAN, if it can be useful (but remember: IN DEBIAN). Debian 8 Jessie. I've found a way to use pc like an headset with Android phone (for making callings). !!! I've use pulseaudio from jessie-backports: I don't know how much this takes risks ;-) !!! In /etc/apt/sources.list ...


1

So I've just come across this thread and found it useful. Flittermice's answer was nearly there for me but I may a slight amendment which seems to have worked well. In the /etc/xdg/autostart/pulseaudio.desktop file the config says to Exec=start-pulseaudio-x11 and if you trace this file it's actually a shell script located in /usr/bin/. This script itself ...


1

that's the old Philippine rice cook principle: one cook, one plate, one fireplace. With other words: Its not possible, its a principle of pairing: one sender one reciever


1

As indicated in https://wiki.archlinux.org/index.php/PulseAudio/Troubleshooting Use load-module module-udev-detect tsched=0 in /etc/pulse/default.pa. This fixes the choppy audio


1

The 3.5mm output jack on the Pi is unique. See this link: http://www.raspberrypi-spy.co.uk/2014/07/raspberry-pi-model-b-3-5mm-audiovideo-jack/


1

Did you try running "amixer cset numid=3 1" to set the output to the audio jack. If that didn't work try the setting the audio output to another interface such as HDMI, if this works then you know that the problem is with the audio jack. Just make sure to use "amixer cset numid=3 2" to set the ouput to HDMI. Have a look at this page here for more details.


1

This worked for me - totally in remote SSH session: Mini Bluetooth Speaker sudo apt-get update sudo apt-get upgrade sudo apt-get install pi-bluetooth ( "already the newest version" ) sudo apt-get install blueman pulseaudio pavucontrol pulseaudio-module-bluetooth sudo reboot hcitool dev (look for bluetooth address of the built-in adapter) ...


1

The default audio out on the Pi models uses PWM for audio, so is not really for hi quality audio.but is enough to make it audible - for example see the tests done here Onboard audio: HiFiberry DAC: If you want better quality you can use a variety of USB Sound Cards, or addon boards like the HiFiBerry.


1

Yes, should be possible (While I don't understand whether those "displays" are supposed to show some kind of graphics output), it is possible for the Pi to source multiple different audio outputs. One simple approach is to use multiple USB sound cards. alsa is perfectly capable to handle multiple cards (see here). Different software tools or multiple ...


1

There are two PWM channels used by the audio jack (left and right I guess). These audio channels can be directed to zero, one, or more gpios as follows. channel 0: gpios 12 (alt0), 18 (alt5), 40 (alt0), and 52 (alt1). channel 1: gpios 13 (alt0), 19 (alt5), 41 (alt0), 45 (alt0), and 53 (alt1). To direct PWM to a gpio you set the gpio to the ...


1

I've got audio piping into a bluetooth speaker with a pi 3 via pulse and MPD. Here's how I got it working: Factory install raspbian jessie (had trouble with lite and bluetooth permissions) onto the raspberry pi 3. Run raspi-config in terminal and expand the filesystem, then reboot. Install pulseaudio bluetooth support via the following command. sudo apt-...


1

I'm in a similar position. But as of Nov 27,2015 I don't think this is supported. I totally agree with you about the documentation issue. When I execute bluetoothctl and poke around this is what I found. Here's why it doesn't work: Bluetooth capability mismatch- Raspberry Pi bluetooth doesn't report a UUID for A2DP, I'm expecting that it should. Also /etc/...


1

You could try using a python library that simply may execute terminal commands and then use pactl to upload an audio sample via pactl upload-sample FILENAME [NAME] and playback via pactl play-sample ID SINK. Be sure the python process is run by a user that can control pulseaudio, and is part of the groups audio, pulse, and pulse-rt


1

There is a way for you to achieve synchronous execution, it's called JACK. You can find more about it here, http://wiki.linuxaudio.org/wiki/raspberrypi. It also explains how to install and configure. Hope it helped.


1

I am having some luck (with 4.99) setting tsched to false when loading the alsa-card module pi@pi $ ./pactl load-module module-alsa-card device_id=0 tsched=false 16 pi@pi $ ./pactl load-module module-sine 17 However, pulseaudo is outputting these messages E: [alsa-sink-bcm2835 ALSA] alsa-sink.c: ALSA woke us up to write new data to the device, but there ...


Only top voted, non community-wiki answers of a minimum length are eligible