Hot answers tagged

14

SSH is enabled by default only for Raspbian releases before November 2016 but the boot protocol for the ethernet interface is set to DHCP by default so the IP address will be assigned by your router. You can find the open SSH ports on your network using the nmap utility: nmap -p 22 --open -sV 192.168.1.0/24 You should find your pi listed in the output ...


9

Depending on your init system, the command may vary. On a Raspbian with systemd you can switch off the system with: sudo systemctl poweroff On a system with SysV-Init system, you can use: sudo shutdown -h now or sudo halt You can, of course, ommit the sudo if you are already logged in as root or su'd before executing.


9

Raspberry changed something since November 2016 here is the noob instruction to get this problem fixed sudo su raspi-config 1) Choose first 'update' 2) In advanced options -> expand_root file system 3) interfacing options -> ssh [enable] 4) change_locale [your country-UTF8] and if you still here, it's good to change the timezone as well 5) ...


8

You don't mention which OS you are using, but there area couple of ways to do this: You can try ssh pi@raspberrypi or ssh raspberrypi.local (this will may need to be adjusted if not using Raspbian - the first part is the username (pi) the second is the host name). You can login to your router and check the device list. You can ping the entire subnet using ...


5

One easy way to solve this is the use of GNU screen, see wikipedia. It allows you to multiplex multiple virtual consoles and therefore to access several different separate terminal sessions inside a single terminal window or via a remote terminal session (e.g. ssh + putty). Just start a (named) screen session with screen -S mysession, do what you want to do ...


4

If I am not wrong, your network setup is - Router <--wifi--> Laptop(Windows 7) <--ethernet--> Raspberry-Pi You need to share your windows 7 (wifi) connection to your Pi (ethernet) port. (http://www.dummies.com/how-to/content/how-to-share-an-internet-connection-in-windows-7.html) and sometimes, your Raspberry Pi will not be able to get IP ...


4

In Windows Command line, or any OS that has ping command you can type in: ping raspberrypi It will resolve the DNS entry and show you the IP address. In the image as 192.168.1.233 But of course, you might just connect using the host name raspberrypi instead of IP. This all assumes that you are using a router with DHCP and DNS running on it. Most internet ...


3

So, I figured it out. A long time ago I assigned an IP to my pi on the router, binding its mac address to the IP. It so happened yesterday that I had the same IP when I needed the pi again. So I probably tried to connect to my windows machine from my windows machine because of the identical IP's. What fixed it was this in cmd (on my windows box): ...


3

sudo shutdown -h now should work and I do this all the time. The -P doesn't hurt, but as the Pi doesn't have power control does nothing. This is the recommended method of halting. It can take a little time to actually shut down. It is possible that some running system process may slow things down.


3

Look at this link: https://tekyblog.wordpress.com/2012/02/02/how-to-setup-x11-forwarding-in-putty-using-xming/ Resolution (as per that website) RPi> su – root RPi> xauth list 10-111-11-11/unix:10 MIT-MAGIC-COOKIE-1 cf4967d5a6c0e6d5f33285aa0e483643 RPi> su – <user> (probably "pi") RPi> xauth add 10-111-11-11/unix:10 MIT-MAGIC-COOKIE-1 ...


3

I seem to have a found a solution, but I'm not sure if there is a better way. I have Pageant (Putty authentication agent) running and I ensured my private key has been added. Putty now authenticates automatically.


3

I had the same issue of "Server refused our key". I found out the problem was using sudo nano authorized_keys. I used nano authorized_keys instead and it worked. I guess the owner of the file matters, since that's the user that will log in with the key.


3

Your permissiong are correct. The default location for the authorized_keys file is ${HOME}/.ssh/authorized_keys. Check the permission of the directory containing the ".ssh" directory. It cannot have group or world write permission since that would allow someone else to replace your .ssh directory. Also, PuTTY and ssh use differently formatted private/public ...


3

I connect to my Pi with ssh pi@hostname.local. This should work with similar GUI ssh programs. You can connect from Linux e.g. other Pi and OS X. This is sometimes problematic with some versions of Windows and networks which use .local in a non-standard way. (See https://en.wikipedia.org/wiki/.local) Give this a try BEFORE you start fiddling with Windows or ...


3

SSh is disabled by default on all new raspbian installs. To enable it you will either need to physically log in and enable it with sudo raspi-config or insert your sd card into another computer and create a file called ssh with no filename extension to enable it on the boot partition. Then make sure it's connected to WI-FI and try again.


3

put the SD card in any computer. A drive will appear (boot). Add the ssh file (without the extension) on the SD drive. Done


3

The boot partition is the first partition on the card, and can be accessed by putting the card in another computer. Depending on what operating system you are using, it may be the only partition you can see, because the others are linux native (ext4) formatted. However, the boot partition is VFAT.


3

After posting this I just found a forum with a related problem. Since I generated the keypair on linux, you must do: ssh-keygen -b [NUMBER OF BITS] -C [COMMENT] -f [FILENAME] -P "". The important bit is the -P "", as it seems to ensure ssh does not require the user to enter a password when the key file is used.


3

You cannot revive the ssh session once disconnected. Sometimes if the network drops for a short enough time the session never disconnects, but once disconnected it is gone. That's a security feature. You can, however, keep your terminal session active between ssh sessions. Check out the Linux programs screen or tmux.


2

I don't know whether it is installed by default, but if it isn't, setting it up is pretty straightforward: in your shell, enter the following command sudo apt-get install ssh after the installation is over, you can start the service via sudo /etc/init.d/ssh start To find the IP address of your RPi, use /sbin/ifconfig and look for the inet line, ...


2

If you want to use the GUI on a remote machine you can use VNC. tightvncserver is available for the Pi. There are hundreds of tutorials on this. You need VNC on your computer, again there are lots of options.


2

Also, have a look at the nohup command.


2

I know this question was for Raspbian Wheezy, just to warn that in Stretch you have to create an empty file called ssh file in boot filesystem to activate SSH at startup. See also: Enabling SSH by default on Raspbian Stretch and Raspbian Stretch Headless Setup Procedure on the Raspberry Pi Forums for more information on how to set up SSH with Stretch.


2

Another datapoint, if its useful. I regularly shutdown via ssh, but I run ssh from the command line (not via Putty). The following shuts down my Pi and powers off (HDMI out becomes disabled, but always on Power LED stays on). Note: this is on Raspbian, and I ran uname to show you my version. The commands below were run remotely from my Macbook. # ssh pi@...


2

Your wifi adapter on the RPi may be going into power saving mode after a period of inactivity. Once you initiate outbound communications from the RPi, it wakes up. I had several RPis with the Edimax nano adapter that would "disappear" frequently, only to reappear a few minutes later. I disabled the power saving options and they've been stable ever since. ...


2

Method 1: Install a network scanner like Fing (free on iOS and Android), scan your WiFi and look for the hostname raspberrypi -- the ip next to it is the one you need. Method 2: Depending on your router's (DNS) configuration, you may also be able to use the hostname in PuttY instead of the ip. The standard hostname is "raspberrypi" so you can simply try ...


2

You'll have to hit it by the IP address - there are ways to get that. Through the Pi Type in ifconfig and you will see your network details. If you are connected through ethernet, it will probably be called eth0. A wireless card will be called wlan0 Through Windows Run CMD and type in arp -a to get all ip addresses that have previously connected with ...


2

Unfortunately not. There's no protocol to connect computers by usb. But there are a lot options to connect PI by wifi (for example making access point by your Mac). Edit: Now i see "putty" tag. So i think that youre not using Mac. Despite it you can still connect Pi and your PC by connecting to the same wifi net (for example your phone hotspot)


2

I know this is an old question but the solution is even older. Male to Male USB bridge networking cables. See the article(from 2005) for a better explanation. Amazon has plenty of similar, if not the same, cables available at the time of this writing(12/2018). While it's not the exact solution to the question I thought I'd add this so future users can be ...


2

Make sure your laptop and your pi are both connected to the same router. Test your Internet connection by pinging, for example, http://google.com on both devices. (ping google.com) On your Pi, in a terminal, type in ifconfig. Look for inet addr:192.168.*.*, and remember that set of numbers (or write them down). That is your Pi's IP address. In your laptop, ...


Only top voted, non community-wiki answers of a minimum length are eligible