Hot answers tagged

58

One of my friends had the very same error which he resolved by following the steps on this page. Apparently there is a/are defect(s) which prevent xrdp working with the vncserver. However it works with tightvncserver Also the order of installation of tightvncserver and xrdp seems to be important. In summary remove the following packages : xrdp, ...


19

Ok so I've done some more digging and several more hours of experimenting, and here's a more thorough answer, including info on how to get xrdp remote sessions to have the nice mouse cursor again instead of the big "X". Background info: It appears to me that Raspberry Pi 3 is the first Pi to come pre-installed with RealVNC, and RealVNC interferes with xrdp,...


4

These two options have been confirmed to work on the RPi: rdesktop and freerdp. These should both work on Raspbian, from within xwin (use startx to get there). You can install either from the terminal prompt using default installer (aptitude). Install rdesktop with this command: sudo apt-get install rdesktop Run like this: rdesktop <hostname/...


3

-a Sets the colour depth for the connection (8, 15, 16 or 24). More than 8 bpp are only supported when connecting to Windows XP (up to 16 bpp) or newer. Note that the colour depth may also be limited by the server configuration. The default value is the depth of the root window. It seems that the server you're using is not offering any other depths besides ...


3

First of all: very good explained question. But it is a sophisticated setup. And just to answer your question: yes, it is needed to setup special static routes on several devices. But it is very difficult to give advices remotely. I would need access to the network to try setup and look how it works step by step, the usual way to do the work of a network ...


3

Found the answer a while back through superuser.com. It was due to the firewall which I disabled using: systemctl stop firewalld.service Src: https://superuser.com/questions/577689/raspberry-pi-fedora-18-arm-remix-remote-desktop-from-windows-7 Also of interest: https://superuser.com/questions/634628/is-there-a-script-to-add-port-forwarding-rule-in-home-...


2

Not understanding how X works. X is made up of many many components. http://en.wikipedia.org/wiki/X_Window_System For Example - the Window Manager manages window decorations, placements etc. the X Server, which everything sits on top of You can actually start the X server with no desktop environment, no window manager, and all you get is a grey screen ...


2

I tried the Raspberry Pi Thin Client project on a Raspberry Pi 2 on a screen with a resolution of 2560 x 1440 pixels. Was a little bit slow on building the screen but much better than installing it under Raspbian.


2

I'm reading this as you want to use your RPi as an RDP client to connect to a remote Windows computer. If this is the case, try installing the remmina package. I've used it as an RDP client to Windows machines, and it works very well.


2

You can do this with the RealVNC server which is installed by default in Raspbian. You simply enable it from the Raspberry Pi Configuration app, and you should see the VNC icon appear in the top right to show it's running. If you click on this icon, go to Options > Troubleshooting and enable "experimental direct capture mode", this will allow you to capture ...


1

As per microsoft implementation you can take only one RDP session at a time. If you want to use more than one RDP session then you need to check the Terminal Service under Windows Server where it requires configuring an Windows Server with CAL license which will cost you too much. There are other ways to achieve this using RDP Wrapper but by taking that ...


1

Thanks to everyone that answered, but I've already found a solution. I used rdektop and systemd . I created a service called remote.service and configured that file to if it closes or exits it starts again. Install rdesktop and then create a service like so: sudo nano /lib/systemd/system/remote.service [Unit] Description=Remote Desktop [...


1

Disabling the wifi interface resolved the problem (well, at least it hasn't come back in a number of days :)).


1

I didn't use the VNC server. Let's check these things before I explain. In the raspi-config is the hostname set for the network? For XRDP working with Remote Desktop Connection, for the username you want to put in the Pi's LOCAL ip address. (Eg: 192.168.1.24) To find out the local IP address you can do (in terminal) ipconfig or ifconfig (I don't ...


1

Try installing x11vnc daemon on the raspberry pi. Then run the command : x11vnc -display :0 -usepw -noxdamage -ncache 10 -ncache_cr Then you'll be able to connect to the active session from your computer.


1

The only solution I'm aware of that lets you connect to the same session that is on a local screen is X11VNC, "a VNC server for real X displays". What you'll need is X11VNC on the Pi and some form of VNC client on your remote device. Install X11VNC sudo apt-get update sudo apt-get install x11vnc Set a password (you can skip it but probably don't ...


1

Just noticed that I never had this answered. Turns out it's pretty simple. Just need to connect Android to USB, enable USB Tethering in Android (Settings --> More Networks --> Tethering and Postable Hotspot --> USB Tethering). Then, on the pi: sudo nano /etc/network/interfaces Add the following line at the bottom: iface usb0 inet dhcp Save and exit, ...


1

I would download a minimal version of Raspbian for your SD card, and then run TightVNC from a script at startup.


Only top voted, non community-wiki answers of a minimum length are eligible