Hot answers tagged

4

Based on your answer that there wasn't a boot partition, your report that the display doesn't work, and an experiment that I've just conducted, I suspect that UNetbootin doesn't do a proper job of installing Raspbian. Since you're just getting started, please try this: Get a copy of balenaEtcher and use it to re-flash your microSD card. Try the boot ...


3

You could always just plug the pi into the USB-C port and SSH in that way. The USB-C can be used to turn the Pi4 into an ethernet device, I've written up instructions on how to set it up here: https://www.hardill.me.uk/wordpress/2019/11/02/pi4-usb-c-gadget/


2

Assuming you have correctly written your image on your SD card, here is schematic about how zeroconf work (as specified by @tpack) if you want contact your raspberry with raspberry.local name. Maybe this can help you better understand. Normally if the OS is correctly written and started RPi must obtain an ip addr on her ethernet interface when you plug your ...


1

You are trying to use an old tutorial for an obsolete OS. You appear to have installed an (unspecified) Raspbian using an unusual tool, which appears to be designed to create bootable drives from an ISO image. I suggest you install a current Raspbian using one of the recommended tools. You can enable ssh headlessly as described in How to set up networking/...


1

The tutorial you reference only enables ssh it does not enable the avahi-daemon (zeroconf) which is what you need if you want to connect via a hostname instead of an IP address. So you'll need the IP address in order to ssh to the pi. Since you are on Linux Mint, try installing nmap and then scanning your network to find the pi. Substitute the appropriate ...


1

There is no simple way to configure a static ip address at the first initial boot after flashing Raspbian to the SD Card. You have to boot at least one time, login and configure the static ip address. On the first boot there is a script running that expands the root partition to the size of the SD Card and do other essential initialization things. You will ...


1

I have found the cause of this, it turned out that eth0 was ending up with two different IP addresses on the same subnet assigned to it. A static IP was being set in cmdline.txt (i'm using an NFS root filesystem) but dhcp was also obtaining an IP address. Modifying dhcpcd.conf to assign the same static IP has cured the issue (disabling DHCP client would ...


1

This answers only one part of your question. For debugging on a serial terminal session you need an USB to serial adapter cable as shown at USB to TTL to UART RS232 COM Cable module Converter. This is very inexpensive but they have very long delivery times from China. You can find also adapters from Adafruit but much more expensive. You can also use a ...


1

I solved it and thank you goldilocks for your answer. Android Side I installed the app Rsync Wrapper on my Samsung and configured it with the following parameters: Source: /storage/WXYZC-ABCD/DCIM/Camera/ Destination: username@192.168.2.4:~/userS8/ Option: -r --ignore-existing --progress -e "ssh -l username -i /data/user/0/net.letscorp.rsyncwrapper/...


1

You don't need to restart the servers. Get the network reconnected. Get the client system reconnected and you're done.


1

The solution is much simpler than finding the IP address. Raspian supports mDNS and that will make the process to find your Raspberry Pi easy as... Use raspberrypi.local instead of the IP address! and if you change the "hostname" on your Raspberry Pi the mDNS address will be yourhostname.local And for the rest I agree with @Milliways answer.


1

You need to enable SSH on Raspberry. Run raspi-config select Interfacing Options and navigate to and select SSH and choose Yes. Then reboot. If you don't have direct access to the Raspberry with a monitor and a keyboard place a file named exactly ssh on the FAT partition of the SD card. This will activate the ssh server at the next boot. You can find ...


1

As shown by your outputs DNS name resolution does not work. That isn't surprising by your mix up of different network management systems. You have openvpn-systemd-resolved installed together with openvpn but you don't enable systemd-resolved.service. If you have it enabled then your link to /etc/resolv.conf is wrong. According to /usr/share/doc/systemd/...


1

Editing /etc/network/interfaces no longer works in Raspbian, as TSGames commented in the most upvoted answer. Instead, you can use /sbin/iw wlan0 get power_save to read the current power save state, and sudo /sbin/iw wlan0 set power_save off to disable power state. Since the iw command is not persistant, I added /sbin/iw wlan0 set power_save off to /etc/rc....


Only top voted, non community-wiki answers of a minimum length are eligible