New answers tagged

0

I ssh from my iMac to the Pi on a daily basis (although I long ago set private keys - so never use password). macOS is quite properly objecting to a potential security breach. This is fundamentally a macOS problem, but you can do a few things on the Pi to make it easier - and you should always do these anyway :- Set a new password on the Pi - it should ...


0

I found a work around "error: No supported authentication methods available (server sent: publickey)". Using "yourhostname.local" for the houstname in putty did not work. I spent the day locating the access to my router. Once there I could see the IP address for the headless Pi Zero. Burned a copy of Buster and brought it up on a Pi 4 with a monitor. ...


0

After ssh, run kodi-remote. I will allow you to control Kodi through keyboard


1

Local address They (the mechanical team who access the raspberry pi) should configure their router to forward incoming port number 22 to the raspberry pi's local IP address which can be recognized by a simple command. ifconfig eth0 It gives them the local IP address which is accessible on their local network. Also, the command below gives them just the ...


4

If you are looking for a procedure to change the SSH default port to another port number like 2222, check the SSH config file which is located on /etc/ssh/sshd_config. sudo nano /etc/ssh/sshd_config So, you would see Port 22 that you can change it to Port 2222. Then, save the file and restart the SSH service: sudo service ssh restart


3

If you typed sudo passwd without any other arguments, you changed the password of the root user. If you want to change the password of a regular user (for example pi), there are two easy ways to do it: Log in as the user and run passwd without sudo. Run sudo passwd pi to change pi's password. You can replace pi with any username that exists on your system. ...


1

Before trying to make an SSH connection, make sure that can your PC ping the raspberry pi? To check it, open terminal on your PC (the operating system does not matter) then: ping raspberrypi.local Or ping it by its IPv6: ping raspberrypi If the result is telling that the host is unreachable or request time out, it's a problem with your network because ...


0

You have already done everything that should work. You only need one USB cable - to the power connector. If you have a windows PC, you might try running NirSoft's "Wireless Network Watcher", and then booting the RPi. It will scan the network and display new devices when, and if they connect. If you are in an environment where you can disconnect other ...


0

Did you set the config.txt file to have the driver loaded automatically? You need to have added the line dtoverlay=dwc2 also cmdline.txt needs to have modules-load=dwc2,g_ether added (I put it just after the rootwait instruction). Also, remember to add a file called ssh to the boot partition to enable SSH. Note - do not edit these files using Windows ...


1

Using Ingo's answer I determined that it was unable to bind to the local address I had specified; so when I figured that out I went into my Unit File (/etc/systemd/system/sshd.service) and added the following two lines: ExecStartPre=/sbin/ifconfig -a ExecStartPre=/sbin/ip addr The on the next reboot, the -ddd output from adding this allowed me to determine ...


0

You could also set up the USB port for networking if you have a Mac or PC you can use - that would give you access via SSH to set up the Wifi using raspi-config. Many tutorials on the net - e.g. one from a random Google


1

Everything seems to to be all right. The only possibility I see so far is to login to the RasPi and analyze what's wrong with the WiFi connection. So you should purchase a keyboard/mouse. You can also use a simple USB cable to connect the RasPi to your Linux computer and use the OTG gadget connection. Then you can ssh into the raspi. You may also consider to ...


1

You can set the debug output on the sshd daemon. Edit /etc/default/ssh and set the option to: SSHD_OPTS=-ddd Then restart the raspi and look at the journal. Here is an example of a successful startup on my RasPi: rpi ~$ journalctl --unit=ssh.service Mar 24 11:08:47 raspberrypi systemd[1]: Starting OpenBSD Secure Shell server... Mar 24 11:08:47 raspberrypi ...


2

A few thoughts: Is you SSID hidden? If so, add scan_ssid=1 one a new line just after the SSID line Make sure the file has only line feeds at the end - no carriage returns You may have a keyboard / language issue. From memory the default until reset is UK English and any other characters used to generate the SSID or pass phrase can give issues. Spaces ...


1

How have you set up the RNDIS network on the Mac? You should find when the Pi is connected the System Prefs / Network page has a RNDIS device created. This is the Macs link to the Pi and determines both the Pi network address and its link to DNS. This assumes your main network is 192.168.1.x and the DNS server is the Internet router at 192.168.1.1 Off ...


1

It works fine when I create a key with PuTTYgen. So it works fine now. Thans for yours help, Nenad


1

As seen from the debug log there is an identity file /home/nedad/.ssh/id_ed25519-cert used for authentication. The log doesn't show that it is denied or accepted and have not finished messages. You should paste the complete log output to the question. B.t.w., using a private keyfile for authentication like you do, it is normal that it is protected with a ...


1

You should be able to set the PreferredAuthentications key in your servers (Pi) /etc/sshd/ssh_config by adding the line PreferredAuthentications publickey and then restarting the ssh-daemon (sudo systemctl restart sshd) or just rebooting. You could also try to log in with this option added to the ssh command and explicitly specifying the private keyfile (...


0

Same thing for me. My PC was on 5 GHz band, Pi on 2.4 GHz band of router. Moved PC to 2.4 GHz, now I can Putty and CMD Ping to Pi ip.


1

A problem that I've encountered multiple times is that I will set the password locally before changing the keyboard layout (which, for me, is English US). The default layout is UK, so when I enter my password it records the characters appropriate to the UK layout. When I then try to ssh into the rpi, the characters that are sent are from the US layout, and ...


2

apt-get remove --purge openssh-server apt-get install openssh-server apt-get purge command removes the program package from your system without keeping the configuration files and any plugins and settings.


-1

It is working now. I have added the following lines to my wpa_supplicant.conf file: country=US ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev update_config=1 change the country code to your own country.


-1

Why don't you just use real vnc?https://www.realvnc.com/en/connect/download/viewer/raspberrypi/ I've used this and it works great. Also, this seems to be a duplicate to this: SSH to RPI using android hotspot and PC Look at here, and see if it gives you any hints. Is you mac also connected to the hotspot?


Top 50 recent answers are included