11

The time gap can be explained because the Raspberry Pi does not have a realtime clock built-in. Raspbian takes effort to make the gap as small as possible and don't always start with 1970-01-01. It stores the date/time from the last shutdown and starts with it. So you will first see this date until the synchronization to the (internet) timeserver is finished....


9

Create file (with subdirs) /etc/systemd/system/networking.service.d/reduce-timeout.conf with content: [Service] TimeoutStartSec=1 On my Pi model B (with Minibian) this solution resolved the problem. Pi boot time reduced to 15 sec, and network works.


5

I solved the problem. First I updated my settings as suggested in the link that Miliways provided in a comment in my original answer. That alone didn't solve it, what I actually had to do is change the configurations in my router: The WiFi was set to WPA2/WPA -> I changed that to WPA2 only and now I can finally connect to the network without problems. If ...


4

I believe an aspect of emergency mode is that the root filesystem is mounted read-only, which is a complication...keep reading. Connecting a keyboard to the device and running suggested command is an option, but outside of this question. Yes. Jessie uses systemd which includes a new-fangled logger, journald. I think systemd is great, but since journald ...


4

You're blowing the power budget. You need an external power supply for your LED strip. You're lucky you haven't trashed your SDCard by losing the power supply when the system is busy.


3

I tested it with the badblocks command on another Linux box and it said there were 0 errors. This is actually a useless tool with SD cards, because SD cards use virtual addressing and there is no guarantee of consistency with regard to the correspondence to actual physical addresses; in fact, even simply reading data may cause it to be physically moved in a ...


3

Run sudo raspi-config and disable 4th option: Wait for Network at Boot.


3

You don't have firmware for this device. Just download this: sudo wget https://github.com/porjo/mt7601/raw/master/src/mcu/bin/MT7601.bin -O /lib/firmware/mt7601u.bin and reboot your machine. Now you should see wlan0 in your ifconfig settings.


3

No. The USB protocol is different to the simple serial protocol used by a UART.


2

Using Google DNS is a sound advice, but you shouldn't set a nameserver manually in /etc/resolv.conf. Instead, consider right-clicking on network connection icon (I assume you're using NetworkManager), select "Edit Connections" and manually add "8.8.8.8" as a name server for your connection. Alternatively, you can configure dhclient to use Google DNS for all ...


2

Not really since it's pretty hard to break a Pi (via software). What I can think of right now: For memory: memtester, can be installed using sudo apt-get install memtester. Usage: sudo memtester <amount of memory to test> <number of times to run test> For GPIO pins: http://wiringpi.com/the-gpio-utility/pin-test/ I think those are the only ...


2

Turns out that my TV-monitor displays interlaced footage really badly, even though it communicated to the Pi that it is able to support it. Whether or not the video output by the Pi is interlaced or not is defined by the "HDMI-mode" set in /boot/config.txt. The mode defines attributes such as fps, screen_resolution or interlaced/progressive. Usually, the ...


2

I had no success applying the many other good solutions to my setup which involves having a macvlan interface on top of eth0. Install based on 2018-06-27-raspbian-stretch-lite. What works well for me: Disable dhcpcd service. systemctl disable dhcpcd Reduce timeout in /etc/dhcp/dhclient.conf. # Do not hold boot for default 60 seconds, give up faster # but ...


2

This was a power supply problem. If you get something like this, check that enough power is being supplied to the Pi e.g. with a multimeter; or if you haven't got one, try a different supply and cable. A faulty cable meant that the Pi was not receiving enough/stable enough power and was unable to power the USB.


2

You are using an inadequate power supply. All of your filesystem problems will be down to this. The power supply warning square shouldn't be on your screen. Get something like the official and recommended universal USB micro power supply or the Adafruit 5V 2.4 Amp + MicroUSB cable power adapter.


2

Another user asked the same question 7 hours later. I seems nobody notices your question. You can find an accepted answer to the other question at Is it possible to upgrade Chromium past v65?. Also have a look at the interesting comments there to this issue.


1

Try to remove configuration and reconfigure the ssh solution here. $ sudo rm /etc/ssh/ssh_host_* && sudo dpkg-reconfigure openssh-server Many similar problem found on Noobs, and this one seems to have verified answer: SSH time out and connection abort


1

After the unzip -p 2017-04-10-raspbian-jessie.zip | sudo dd of=/dev/sdX bs=4096 command there should be two partitions on the the new sd card, the first is start up and has to be a fat partition and the second has the root filesystem. To start over again (as Goldilocks comment) format the sd card from beginning to end in fat32 format. sudo fdisk /dev/sdX # ...


1

I found the solution: sudo apt-get install alsa-utils sudo apt-get install mpg321 sudo apt-get install lame sudo modprobe snd-bcm2835 Enabling Audio Output By default, the RPi audio output is set to automatically select the digital HDMI interface if its being used, otherwise the analog audio output. You can force it to use a specific interface via the ...


1

It is possible to backpower the Pi through the USB but I am pretty sure doing this and providing power via another means is probably a bad idea -- as in one which may lead to damage. If that Corsair keyboard is backpowering this way, it may be defective, since that is definitely not something that is a good idea to do to a normal computer (plug a voltage ...


1

I think that this version of Jesse is defective. It is meant to work with the resistive touchscreen created by Aafruit but it doesn't seem to. Can't find a solution anywhere. Seems like you have to go back to a previous version of Raspbian and manually install the script by Adafruit so you can get the touchscreen to work and the pi to run. This process ...


1

Does anyone know how I can fix this, to satisfy both conditions? Perhaps, but not in a canonical way ("proper practice") way without examining the system (I've never used minibian), and learning more about how network configuration on GNU/Linux in general is supposed to work, because I've never used it properly. All my debian style machines, including pis, ...


1

I don't have the reputation to comment on the accepted answer yet. But just a quick update on the answer, for the latest Raspbian Linux raspberrypi 4.9.59-v7+ #1047 SMP Sun Oct 29 12:19:23 GMT 2017 armv7l GNU/Linux The file you want to edit is: /etc/systemd/system/network-online.target.wants/networking.service It already exists,and you should edit the ...


1

The documentation said your syntax should be; ffmpeg -i input.mp3 -f s16le -ar 22.05k -ac 1 pipe:1 | sudo ./pifm - - is common and pipe:1 is not, but that's what it supports.


1

I've had problems before with using a pre-shared key, especially when I forgot to escape characters that needed to be escaped. Characters that may need to be escaped would be (among others): {}\[]<>?;~@" You escape a character by adding a '\' before it, so for example if your key was: P@ssword"! You would escape it like: P\@ssword\"\! Likewise, ...


1

As @Ghanima pointed out, apt-get doesn't have the ability to know about every file that's installed on the system. Most files that are put under the user directory (/home/pi in this case), are done after the installation process. An Example: There's good reason for this. Let's say you install a package called foo, and your only user on the system is pi. ...


1

Sharing the eventual solution: I have a small Digital Ocean VPS that I use to host a few websites. On the Pi, I create a tunnel from my VPS to the router with: ssh -R 7700:[router_local_ip]:7700 user@vps.url That gets a request to 7700 on my VPS inside to the router, from there the router's normal port forwarding options let me pass that on to 7700 on the ...


1

To access a specific port on your Raspberry Pi behind a complicated multi-tier firewall you could use a service like ngrok. For one port it's free, it should only take about 5 minutes to sign-up and configure it on your Pi. For a one time thing or for a single device behind a very dynamic connection (3G for example) that does need to be 100% secure it ...


1

No, there's no rabbit hole. Your ISP may be using private IP addresses and NATing everyone's traffic. In short, you and everyone using your ISP is behind a giant firewall. I recommend you call them. The may either provide you the ports you need and a public IP address for free, or they'll offer you a "business-class" connection with a public IP address and ...


1

Add nameserver 8.8.8.8 or your preferred dns server to /etc/resolv.conf


Only top voted, non community-wiki answers of a minimum length are eligible