Hot answers tagged

17

The username is "pi" and the password is "raspberry", you have misspelled the word "raspberry" by missing the p. If you still have issues, I would try re-downloading, re-formatting, and doing it once more. I think you'll be fine after correcting the password entry. It's good practice after logging in to change the password of the user from the default. ...


17

Assuming a new name of username: To create a new user account: sudo addduser username Follow the prompts, being sure to set a good password when prompted. You also want to add the new user to the same groups that the pi user belongs to. You can view the groups the pi users belongs to with groups pi. groups pi pi : pi adm dialout cdrom sudo audio video ...


11

Defaults are Username: root Password: centos


9

You can manually modify the raspi-config script as follows. Let's presume we're using the username "bob". sudo nano /usr/bin/raspi-config then search for do_boot_behaviour() {...} Under that, there's a line where we will replace the "-u pi" with "-u bob", leaving the rest of the line unchanged: if id -u pi > /dev/null 2>&1; then Next edit the ...


8

As it turns out, you don't have to flash your RPi to recover from this. In fact, you don't need another Linux system at all, all you need is another SD card flashed with your RPi OS flavor of choice and a USB SD card reader to put your original SD card in. The init=/bin/sh method did not work for me (I think there was a display conflict with the custom ...


7

So, www-data is the owner and owning group of /var/www. That doesn't mean anyone in the www-data group can write to /var/www. You still need to give them write access: sudo chmod g+w /var/www


5

Create the user like normal and setup the auto login how you want it, Then add the user to DenyUsers in /etc/ssh/sshd_config e.g. DenyUser autologinuser Restart ssh after you update the config file. Reference : http://linux.die.net/man/5/sshd_config


5

According to the Debian Wiki: staff: Allows users to add local modifications to the system (/usr/local) without needing root privileges (note that executables in /usr/local/bin are in the PATH variable of any user, and they may "override" the executables in /bin and /usr/bin with the same name). Compare with group "adm", which is more related to ...


5

SSH SSH is achieved just by creating a new user (useradd) and making a small edit to sshd_config. First lets create the user: useradd UserName passwd UserName Once the user is created, if you want it to have root access, add it to the sudo group: usermod -aG sudo UserName Next we want to edit the sshd_config as root: sudo -s nano /etc/ssh/sshd_config ...


5

You can manually add the user to sudoers, but this is only part of the story. If you want the user to have the same privileges you should set the groups. The pi user is normally a member of pi adm dialout cdrom sudo audio video plugdev games users input netdev gpio i2c spi This can be done with the following command (replace username with the actual name). ...


4

I had changed the pi user name and disabled the root account password, then followed direction in the previous answer including the suggested edit to this: sed /etc/lightdm/lightdm.conf -i -e "s/^#autologin-user=.*/autologin-user=pi but as Brandon indicated in his answer, I also had to edit the lightdm.conf file. Otherwise I got the graphical login prompt ...


4

It was probably the pi user; the only two login accounts initially are pi and root. pi is user and raspberry is password initially. UN = pi PW = raspberry


4

This isn't peculiar to Raspbian or even GNU/Linux; evidently it's used on OSX too, although perhaps not the same way. Both operating systems are a form of unix -- I found that OSX question by quickly searching "unix staff group". OSX actually aims for (and receives) certification from SUS and POSIX; the use of staff there may be to comply with the former. ...


4

Login as the pi user, right click the vnc system tray icon and select options, go to the users and permissions page and add your new user there. By default it should allow users that are members of the sudo group (which includes the pi user by default)


4

I think I tracked it down for you... You removed the lightdm autologin for user pi ... but, if you are using noobs, there is another autologin here: /etc/systemd/system/autologin@.service line 28: ExecStart=-/sbin/agetty --autologin pi --noclear %I $TERM So, it seems that noobs is has two locations for autologin with the user pi Remove the second one, ...


3

just faced the same problem. everything written before is right, BUT : my installation had an english keyboard layout, which means, to input my "raspberry" pw i had to press "raspberrz"


3

When you type sudo passwd you are running the passwd command as the root user, and you are therefore changing the password of the root user, not of the user pi. Only the third time, when you changed the password using just passwd, did you actually change the password of the pi user. The three users you see are just 3 different login sessions for the same ...


3

You may want to have a read over the invocation section here, and note that sh on Raspbian is actually a link to bash, which will conform to sh type behavior when invoked that way. However, because of the naming collision with "remote shell", which the latter won, /usr/bin/rsh is not what you are looking for. I'd try /bin/rbash instead.


3

If you run adduser with the same group as pi this should work (I haven't tried this). As per the comments above this is the hard way to solve your problem. Just give each Pi an unique hostname and they should be easy to distinguish. It is preferable to have the same username on each machine if you want to move files around.


3

As of Raspberry Stretch you can simple login to youruser and call sudo -s raspi-config and in the Boot Options Menu "B" under "B1/B2" you'll find .. automatically logged in as 'youruser' user will be available as an option. Select it and reboot.


3

As lenik sayed, echo is a built-in and thus cannot be used with sudo like that. But in your case, it's the redirection (>) which cause problem (thanks goldilocks). Indeed, the redirection is also made by the shell and thus have the same restriction than the built-ins. Instead, you should switch to root first: $ sudo su # echo 24 > export Or if you don'...


3

On Raspbian you have two common options: Option 1: Add the already created user (i.e. with the name "john") to the group "sudo": pi@raspberry:~ $ sudo usermod -aG sudo john Option 2: Edit the sudoers file: pi@raspberry:~ $ sudo visudo By default you'll find this line (do not remove/overwrite it): root ALL=(ALL:ALL) ALL. Just add john ALL=(ALL:ALL) ALL'...


2

In my case, I did not actually change (or delte) the default user "pi" user, I simply created a new user for myself and wanted to boot to that user by default. In that case, even after doing the above, I still ran into the issue of the system booting to the "pi" user by default. For some reason, the sed line was not actually updating lightdm.conf. So I ...


2

Your problem has nothing to do with only one user or starting LXDE on boot. I normally connect with ssh then start tightvncserver and have noticed similar. In addition the font becomes smaller. I don't know what is happening; I note a new lxsesson is loaded, and I assume it is bypassing some initialisation. Sometimes it does not restart. The only way to ...


2

After uninstalling lighttpd and installing it again the problem has been solved. But I still don't know why!?


2

No, the system does not impose a limit (not quite true but the limits are well beyond what you would sensibly do in practice). In practice the number of users logged in will be limited by how many you can find a reason to simultaenously use. If I was carrying out a test I might log in as the same user a dozen times, with each window showing a different ...


2

As I can't tell what else happened to the system I'd recommend you to first reflash the sdcard. Secondly create new user and add it to sudoer group and then lock the pi user. passwd pi -l Then reboot the system. It should work, check the running processes what user they use ps aux If everything checks out and no process is running with pi user, then go ...


2

and had to spam passwords in until I got it right the user name and password is mentioned in the official website root password : centos https://wiki.centos.org/SpecialInterestGroup/AltArch/armhfp if it changes in the future, the change will be in the official website.


2

If I wanted to do this (and I still think it is futile - pi is just a text label for user 1000, and the number can be used in many contexts), I wouldn't do it on a working system. AFAIK the string pi only appears in 3 places; /etc/passwd, /etc/group and a directory in /home. I would just edit in the appropriate files on a mounted image. (I haven't actually ...


2

First, delete the user created. Next, I type $ groups pi to check the group's user pi belong. Then I create a new user with the command $ useradd -m -G [groups from user pi except for pi and sudo] username. The -m option creates a home directory and -G [groups] option adds the user to those groups. Set up a password to the new user with $ sudo passwd ...


Only top voted, non community-wiki answers of a minimum length are eligible