Hot answers tagged

37

You should install x11vnc and configure it to get same screen on HDMI and also vnc client. apt-get install x11vnc then run x11vnc command with parameters. x11vnc -display :0 -usepw -listen IP_of_pi -allow allowed_ip_address -display : screen number to get -usepw : use password security -listen : IP address of server (Pi IP) -allow : allowed client ...


33

First install autocutsel (sudo apt-get install autocutsel) Then open your /home/pi/.vnc/xstartup (nano /home/pi/.vnc/xstartup) and put autocutsel -fork on it like this: #!/bin/sh xrdb $HOME/.Xresources xsetroot -solid grey autocutsel -fork #x-terminal-emulator -geometry 80x24+10+10 -ls -title "$VNCDESKTOP Desktop" & #x-window-manager & # Fix to ...


32

I know this was asked a long time ago, but I found an solution to this problem. If you start it using display :1 (or something more than 0), you have to enter the IP like this: 192.168.x.x:590<displayNumber> (like this 192.168.1.23:5901). I hope this helps a future user


23

If look at the /etc/init.d/skeleton script, in the beginning of it there are two marks : ### BEGIN INIT INFO and ### END INIT INFO. All the data inside those marks is the configuration for runtime dependences and you can look them up in the Debian Wiki. Your script is missing these tags and configuration so insserv just uses some defaults. This is just a ...


21

Found a fix, edited /boot/config.txt enabled these configs: framebuffer_width=1280 framebuffer_height=720 Note - on some versions of Pixel you may need to create this file as it may not exist. For example using a Kali Linux version and this file did not exist but worked for a headless implementation once created after a reboot.


20

Headless VncServer Configuration If you need to configure accessing the pi with osx's Screen, but only have headless access to the pi, you can use a vnc config file. sudo raspi-config > Interface Options > VNC > Enable. Reboot. Generate the password you wish to use in screen with vncpasswd -service sudo vncpasswd -service Create and edit the following ...


15

The error message is quite clear. You are missing a X enviroment , so install it : sudo apt-get install xserver-xorg-core xserver-xorg-input-all \ xserver-xorg-video-fbdev libx11-6 x11-common \ x11-utils x11-xkb-utils x11-xserver-utils xterm lightdm openbox


15

In the desktop menu, go to Preferences > Raspberry Pi Configuration and click the "Set Resolution" button. Or, from the terminal, run sudo raspi-config and choose Advanced Options > Resolution. If you have a monitor attached, it will show a list of modes supported by the monitor. If you don't have a monitor attached, it will show a list of the most common ...


14

To make the answer a little more explicit, here are all the steps I took to get it working: On the raspberry pi Install tightvnc server (designed to support lower bandwidth) sudo apt-get install tightvncserver Configure vnc desktop with screen resolution and color depth vncserver :1 -geometry 800x600 -depth 24 On the mac Enable the native vnc client ...


14

To be able to use a non-compatible realvnc client you have to downgrade the security of the realvnc server to use vnc password authentication. To be able to to this without a desktop connection open a SSH session: Edit the config file in /root/.vnc/config.d/vncserver-x11 Add the following lines at the end of the file Authentication=VncAuth Encryption=...


11

The best part of using your Mac to access the Raspberry Pi's screen is that you don't need to install anything on the Raspberry Pi or the Mac. (KISS rule applied!) This is good because software like tightvncserver requires Java to run on the Pi. Java is handy but it is a processor pig and should be avoided to keep your project running as fast as possible; ...


10

Your most likely using TightVNC and it's behaviour does not allow access to the real (to my knowledge) x desktop session. What your looking for is x11vnc. This allows VNC access to the default X session. Not exactly sure what Distro you are running, but first try installing it apt-get install x11vnc. If that does not work, then you will have to download ...


10

Typically a port around 5900 is used for VNC. In your case, you could try 192.168.1.127:5901. The last digit (1 in this case) refers to the virtual display of the VNC server. It usually starts at 0, meaning 5900 is the standard display/port to connect to.


9

In the question you said "The Pi is not quite powerful enough to run the application that I would like" and you also said "On the server, I only need to be able to run Chrome." So I'm going to assume that you're trying to run some kind of web app with some dynamic page loads (ie ajax or flex/flash). I would suggest that rather try to do the server/client ...


9

To do this you can use a little bit of Linux cleverness. Our first task will be to edit the file /etc/rc.local. This file can contain commands that get run on start-up. If we look at the file we can see that there is already few entries in there; #!/bin/sh -e # # rc.local # # This script is executed at the end of each multiuser runlevel. # Make sure that ...


9

See @Andrew Wedgbury 's comment to the accepted answer. " It is now possible to do this over VNC. If you're using the RealVNC server on the Pi, go to VNC options > troubleshooting and enable "experimental direct capture mode", then you'll be able to view the camera preview image over the vnc connection. – Andrew Wedgbury May 31 at 8:53 " This worked and is ...


9

later I found out another solution to make it work for Remmina 0.9.99.1. You can change the security authentication for the VNC server to be VNC Password instead of Unix password and create an admin user credentials so you can use it in the remote connection as the following: On VNC Server side on Raspberry Pi 3 Go to the options on the VNC Server on ...


8

A new version of RealVNC Server was made available in the repositories yesterday. If you have recently updated your packages and installed this new version, then you will need to restart any running VNC server instances. It's probably easiest to simply reboot if you can, but if not you can restart the servers. If you're using the service mode server (i.e. ...


7

You have 2 options Install tightvncserver on the Pi, or Install RealVNCviewer on your computer.


6

The fonts are missing because the xfonts-base package is not installed on your server. Install it with sudo apt-get install xfonts-base


6

I ran into the same problem today and I could get rid of some of the warnings by installing the two packages: sudo apt-get install xfonts-75dpi sudo apt-get install xfonts-100dpi Update I got it working using x11vnc rather than tightvncserver or vncserver This post set me on track. So first I connect to my PI using ssh ssh pi@rasperrypi Install x11vnc ...


6

Set or uncomment, the following lines, in /boot/config.txt hdmi_force_hotplug=1 hdmi_group=1 hdmi_mode=16 # (or any other pi resolution you want, 16 is for 1080p) Reboot your Pi (sudo reboot) and done!


6

From this Raspberry Pi forum post: In /boot/config.txt, I set hdmi_force_hotplug=1 and hdmi_group=2 hdmi_mode=16 (1024x768@60Hz) Then I ran x11vnc with -configure 1024x600, which is the resolution of my netbook screen If you cannot get that to work, I would recommend using a different VNC server altogether. The one I use is ...


6

What you would need to do is create a reverse SSH tunnel. You would have to configure the Pi to do this before you place it at the remote locations. What happens is the Pi creates a connection from inside the network. With normal NAT that is considered safe and the connection is established and any data that comes back is routed to the correct IP. Some ...


6

All hardware accelerated players go directly to the video hardware (overlay). You can only view them on a monitor connected directly to the Pi.


6

Either install the RealVNC viewer on your Mac, or change the authentication type on the server to "VNC Authentication" and set a suitable VNC password. The Mac viewer doesn't support RealVNC's system authentication, which allows you to login as a system user.


5

Finally I've made it! The procedure was almost correct. I was just missing a few little details. First, the timings: putting /usr/lib/vino/vino-server directly in lightdm autostart launched it before the X session was completely set-up. So I wrapped it into a script with a little bit of delay before the command: #!/bin/bash sleep 5 /usr/lib/vino/vino-...


5

Before starting ensure your Pi is connected to the internet\network via Ethernet\wifi. Open the Terminal and enter the following commands: Get Pi IP Address for remote connection (for use later) hostname -I Install TightVncServer sudo apt-get update sudo apt-get install tightvncserver tightvncserver The first time this is run you must enter a password ...


5

The camera preview seems to be handled on a low level in the GPU, and is visible only on a monitor connected directly to the Pi. Any program that shows the camera image in a regular X window should be viewable over VNC. If you want the video sent over the network, you might consider stream the video instead. Streaming is easy, the only issue is that that ...


5

I'm assuming you have an RPi 1 (single core processor). Your code is far too intensive for any single core machine, and is terribly inefficient (but may sorta work) on a multicore machine. The problem lies in the logic of your code. You are using what's called "polling". Essentially, you're the kid that's constantly asking, "Are we there yet? Are we there ...


Only top voted, non community-wiki answers of a minimum length are eligible