Hot answers tagged

3

I did something similar. Now this isn't a bridge because it's using NAT, but you mentioned NAT so I think you really just want an AP Client Router. You could also genuinely route across the Pi just by binding a network to each side and giving it a route to use (like a default) after enabling IP forwarding. But that tends to give people a harder time to do ...


3

Sniffing other WiFi networks you are not associated must be supported by the WiFi chip, called monitor mode. If you look at the chip configuration on the RasPi with: rpi ~$ iw list Wiphy phy0 --- snip --- Supported interface modes: * IBSS * managed * AP * P2P-client * P2P-GO * ...


2

You have two connections to your internet router, one wired on interface eth0 and one wireless on interface wlan0. The RasPi only uses one connection determined by the metric of the route. You can show the route with: rpi ~$ ip route There you will find the metric. The route with the lowest metric is used. I suppose its the wired connection. With the ...


2

Remove packages: apt-get -y remove hostapd dnsmasq bridge-utils Comment the line below from /etc/sysctl.conf: #net.ipv4.ip_forward=1 Reset iptables: iptables -F Delete following lines from /etc/dhcpcd.conf: interface wlan0 static ip_address=192.168.4.1/24 nohook wpa_supplicant Restart the dhcpcd daemon: sudo service dhcpcd restart ...


2

Use a systematic testing procedure, rather than a shotgun approach. Try a fresh Raspbian on a new SD Card If this works the hardware is OK, if not you have probably damaged the Pi. Only if WiFi works on an unmodified OS try software fixes. As always the BEST solution is to restore from your backup.


2

Results of a test with a Pi 3 A+, following instructions from here; Second SD card via SDIO 1-bit 1) Second SD card appears as /dev/mmcblk1 2) Integrated WiFi interface does not appear in ifconfig Second SD NOT enabled 1) Second SD card is ignored 2) Integrated WiFi interface appears in ifconfig, and is functional No, you can't have both, they are ...


1

What you want to do isn't an easy task and without exact information about your network setup, in particular about the vpn tunnel there cannot be said much in detail. But here are some ideas as far as I can see. You have two default routes but the RasPi can use only one, the one with the lowest metric, in your case the route through interface eth0: default ...


1

The problem with a Raspberry Pi is, that it cannot bridge a client connection on interface wlan0 to a remote hotspot. This needs hardware support on the WiFi chip, which isn't available. But there is a workaround to emulate a real OSI layer 2 bridge using proxy arp. This is not a real bridge but it behave like one. How to setup it you can look at Workaround ...


1

Two ways I can think of: First way does not need the Pendrive but is a bit of a clat: I would set the Pi up to be an access point using WiFi Connect from Balena. Then when you power on the Pi you can use anything to connect to its access point and give it the locations WiFi details. Just before you leave, reset the Pi to use the WiFi connect at the next ...


1

As @Ingo has pointed out, RPi Zero W is not your best choice for a radio. As a suggestion on how to proceed, perhaps read this tutorial on sniffing wireless packets, and then visit the WireShark website. As far as the radio itself, you might try looking for a USB dongle that uses the Atheros chipset. Here's a resource that may help finding a manufacturer. ...


1

Let's have a look at the logic. With default setup you have two interfaces: eth0 wlan0 With an additional GPRS dongle you should see: eth0 wlan0 ppp0 With your setup you see without dongle: eth0 ppp0 and with dongle: eth0 ppp0 wlan0 Do you see it? In the first case wlan0 is always available, in your case it is ppp0. It seems something is making wlan0 ...


1

I haven't heard before from an USB/WiFi dongle that emulates a wired connection eth0. Normally a wireless interface, used for a client uplink connection, cannot be added to a bridge. This is only possible with wired connections. For further information you may have a look at Raspberry Pi WiFi to Ethernet Bridge Anyway, with your nice dongle it seems to be ...


1

I’ve not tried this but I think this maybe what you need assuming you are using Stretch or Buster. man SYSTEMD.LINK 5 Also at udev systemd.link Example 2 shows: This example assigns the fixed name "dmz0" to the interface with the MAC address 00:a0:de:63:7a:e6: [Match] MACAddress=00:a0:de:63:7a:e6 [Link] Name=dmz0 I personally would make sure both ...


1

It seems OMV completely occupies the network setup with its own settings and destroy the default Raspbian networking with dhcpcd. OMV modifies /etc/network/interfaces and claims to use systemd-networkd for network setups. Both systems are not used by Raspbian so I'm afraid you are without luck to use OMV with Raspbian if you do not find instructions from OMV ...


1

Thanks to @Ingo suggesting a fresh installation of Buster, I was eventually able to track down the problem, which was due to an update in the package firmware-brcm80211. The current release of Buster (2020-02-13-raspbian-buster-lite) comes with firmware-brcm80211 1:20190114-1+rpt4 and upgrading to firmware-brcm80211 1:20190114-1+rpt5 causes a failure to ...


1

From the debug output of wpa_supplicant I see there is the old background driver wext used and that there are many "unsupported" messages. wext isn't used normally, you should use default background driver nl80211. That's what is best supported by Buster. Debug again but only with option -Dnl80211, not with fallback option -Dnl80211,wext, and show if it ...


1

For the future, you can get hints about missing commands directly in the command line: $ sudo apt install command-not-found $ sudo update-command-not-found $ dkms The program 'dkms' is currently not installed. You can install it by typing: sudo apt-get install dkms Of course it's not smart enough to tell you that dkms is indeed the command you need, or ...


1

Automatically installing Linux kernel modules with the DKMS framework is a convenient way of distributing drivers that are maintained outside of the official kernel. However, while DKMS is included in many popular Linux distributions and supports most kernel modules, it can’t always guarantee the proper installation of a third-party module. Source ...


1

Configure the /etc/wpa_supplicant/wpa_supplicant.conf as the link below because it has not configured in a true way and some part of it has lost: Setting WiFi up via the command line My /etc/wpa_supplicant/wpa_supplicant.conf is like this and is working: ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev update_config=1 country=IR network={ ...


1

The tutorial you linked is for Raspbian which uses dhcpcd as its network manager. Ubuntu Server uses systemd-networkd with a yaml front end. You COULD install network-manager (or dhcpcd for that matter) but you would be better to configure systemd-networkd. See Access point as WiFi router/repeater, optional with bridge (I have not tried this myself) PS ...


1

Ubuntu Server uses Netplan to manage its connections. To create an access point using Netplan, you can do the following: 1. Install Network Manager sudo apt update sudo apt install network-manager 2. Disable cloud-init sudo bash -c "echo 'network: {config: disabled}' > /etc/cloud/cloud.cfg.d/99-disable-network-config.cfg" 3. Create a Netplan ...


1

I replaced the out-of-the-box NOOBS card with a pure Raspbian install. Worked just fine. Yay Raspbian, Boo NOOBS!


1

NOOBS has to access networking and has its own mechanism, independent of Raspbian. Normally it re-configures Raspbian on installation. It may be overwriting the Raspbian settings. Unfortunately you are unlikely to get help on NOOBS on this site because most experienced users don't use it. I suggest you reboot the the NOOBS setup and try disabling there. ...


1

It is difficult to know what state your Pi is in; certainly the /etc/network/interfaces as listed will stop dhcpcd from running. From your comments it appears you are using NOOBS None of us do - it just makes subsequent updates and support harder. I strongly recommend you follow Dougie's suggestion and do a fresh install. You might like to use the new ...


1

This is a little weird but happened to me: just verify that there is a wpa_supplicant.conf file in /etc/wpa_supplicant/, I had deleted it and it was causing the problem.


1

How have you set up the RNDIS network on the Mac? You should find when the Pi is connected the System Prefs / Network page has a RNDIS device created. This is the Macs link to the Pi and determines both the Pi network address and its link to DNS. This assumes your main network is 192.168.1.x and the DNS server is the Internet router at 192.168.1.1 Off ...


Only top voted, non community-wiki answers of a minimum length are eligible