New answers tagged

0

I believe I have found out what was causing my problem. I still don't fully understand ARP, but thanks to all those who pointed me to ARP as the likely cause, I have done an experiment that shows how I can run my server without losing connectivity from various clients. Let me explain: I originally deployed a single copy of this server on a Raspberry Pi 3 ...


0

You should do tcpdump on your client and server to figure out where the protocol is going wrong. In passive mode, the server opens a connection on some random port and the client connects to that for data transfers. A lot can go wrong, with NAT, with security and with firewalling. You need a packet-inspecting firewall to selectively open the port for the ...


2

This could be an issue with ARP not being able to resolve the MAC address of your Pi Zero W. Each host maintains an ARP cache mapping IP address to MAC address for connected LAN networks. When a host needs to connect to some LAN-connected address (say 192.168.1.1), it will first send an ARP who-has request (tcpdump output): # tcpdump -n -i wlan0 arp ... 18:...


0

According to: This post! dated: 2019-11-27 13:23 It appears that pi 4, until an update is released, will have wifi connecting problems on higher resolutions. you need to bootup your pi at lower resolutions (for me it worked at 640 * 400). After booting you can switch to high resolution!. I tried other resolutions too but for me 640 * 400 only works!


0

I assume you have installed Raspberry Pi Os Buster. If it's not buster, first download it from https://www.raspberrypi.org/downloads/ and try again. Buster uses dhcpcd to enable detected WiFi interfaces. In particular, when a WiFi interface is found, dhcpcd will launch: wpa_supplicant -B -c/etc/wpa_supplicant/wpa_supplicant.conf -iwlan0 -Dnl80211,wext This ...


3

Enabling VNC shouldn't touch your WiFi configuration. I suggest your WiFi interface disappeared for some other reason. Now that you have a fresh install, try going ahead with that. Aside: if your original install had a lot of customisation making it problematic to start again from a fresh install, consider using puppet to configure your system in a ...


1

AFAIK there is no GUI tool, but it can easily be done by editing a couple of files. See Use different wpa_supplicant files in How to set up networking/WiFi


0

If you are using a Mac be sure to turn on 'Show file extensions' in Finder or the file could get a additional .txt extension wpa_supplicant.conf.txt) if created in Texteditor.


1

It is difficult to understand with your description what may be the problem. I assume it is mainly due to the installation of pihole. I suggest to verify first your network environment by using a default Raspberry Pi OS (32-bit) Lite. Follow the official documentation to enable SSH (Secure Shell) and WiFi by Setting up a Raspberry Pi headless. This must work ...


0

This could be a false positive, but the symptoms (unspecific as they are) match up with the answer I provided here. In short, it seems some clients fail to connect unless you disable WPA2 with proto=wpa, or wpa_supplicant is replaced with something that provides an WPA2 Authenticator like hostapd.


0

This appears to be a broader insidious issue with wpa_supplicant (on Debian only?), and not limited to the Pi. After many, many hours of following misleading symptoms, I can confirm that with: wpa_supplicant 2.8 on Debian Buster with default config plus mode=2, ssid and psk set, and every permutation of pairwise, group, auth_alg, frequency that could ...


2

A terminal is usually a monitor with a keyboard and mouse attached to a computer device. I assume you do not mean that, but a computer device like a PC, Laptop or smartphone. You also write that you use a network bridge on the RasPi. This isn't possible with a WiFi client connection to the router because lack of hardware support of the on-board WiFi chip. ...


-2

You have to enter your router settings and search for your device MAC. Then set that as a static IP. Then also make a static port and then configure your router. Then you can register the IP in the router and enter rpi from that terminal. The thing is you have to know what to do with your router. I am sorry for not giving you any details since I use a ...


1

I was able to find an answer, I don't know if it is the right one for the application, but it worked. import subprocess cmd_permission="sudo chmod 777 /etc/wpa_supplicant/wpa_supplicant.conf" subprocess.run(cmd_permission, shell=True) cmd="sudo echo "network={ssid="rede" psk="pass" key+mgmt=WPA-PSK}" >> /...


2

I would have commented but don't have enough reputation. Ingo's answer almost worked for me. However there was a weird bug where the virtual interface was not removed sometimes. Apparently (source: https://github.com/seemoo-lab/nexmon/issues/221) this can happen because the broadcom driver crashes when the pi is started up without wifi. The solution is to, ...


2

Your problem is well known as dynamic failover and supported by Linux with its bonding driver. It will switch to the next connection as long as it is connected. The first step is to bring up all connections. I prefer to use systemd-networkd so Use systemd-networkd for general networking. You will find examples in section ♦ Create interface file for a wired ...


0

I had this exact same problem, and I diagnosed it. In short, the problem is your choice of WiFi adapter. The RTL8188EUS / r8188eu does not work properly with out of the box software configurations. This is evident in your log messages: May 3 00:04:05 raspberrypi dhcpcd[306]: eth0: waiting for carrier May 3 00:04:05 raspberrypi kernel: [ 11.679881] ...


1

For those who struggle on how to set the registry key: I did it via PowerShell (launch Power Shell in IoT Dashboard) with the following command Set-ItemProperty -Path HKLM:\SYSTEM\ControlSet001\Control\Class\"{4d36e972-e325-11ce-bfc1-08002be10318}"\0002 -Name WFDChannelNumber -Value 13 Edit However setting the value to 13 didn't bring the desired ...


2

It may be possible that wpa_supplicant is modifying its configuration file for some reason to permanently store configuration changes but with the change it will not work anymore. This is manged by the option: update_config=1 Set this option to 0. This will wpa_supplicant prevent to change its configuration file so you have excluded this possebillity.


1

You answer your question and asked for details: "Can anyone explain this?". As shown with ip addr the wlan0 interface is down. So you have to look why it doesn't comes UP on bootup. Using /etc/network/interfaces for it isn't not a good idea because it may disable dhcpcd partial and you have exactly to know what you are doing. Just for testing flash ...


0

I actually got it working, but I have no idea, why this was not configured correctly in the first place. I had to go into the /etc/network/interfaces and add: auto wlan0 iface wlan0 inet dhcp wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf The file was completely empty, except a statement to include /etc/network/interfaces.d, an empty folder. It ...


0

Had the same problem. I was connecting Pi to my mobile hotspot. No hope. Renamed the hotspot and removed all the spaces, it connected! I used a 2.4ghz WPA2-PSK connection. Hope that helps!


1

If the drivers are only available on ubuntu your only option would be to try compiling the drivers from source. Download the tar.gz file and try to compile it. It won't be very simple but it's worth a shot. A few links.


0

If I understand your rather vague Question you are asking about the allocation of names to Network Interfaces. You should use Predictable Network Interface Names which have been used in other distributions for some time. These are designed for multiple network interfaces to eliminate the enumeration race condition. There is an option in raspi-config to ...


0

Change the APs SSID on the 2,4GHz and 5GHz so they do have separate names. The other solution is to specify the parameter freq_list in the file /etc/wpa_supplicant/wpa_supplicant.conf: ctrl_interface=/var/run/wpa_supplicant network={ ssid="Your_AP" psk="Your_Passphrase" freq_list=2412 2437 2462 } Ref.: https://askubuntu.com/...


1

Making that choice on the Raspberry Pi seems to be a problem. I would have thought that bssid or bssid_blacklist would have worked for you, at least. Being able to choose which access point to connect to based on BSSID is rather important... I've tried to limit a Pi 3B+ to 2.4 GHz frequencies using the freq_list parameter in wpa_supplicant.conf, but with no ...


0

I added an external antenna without a mini SMA socket or disconnecting the onboard antenna. This is to control a resin 3D printer that's enclosed in a metal chassis. It's simply a wire connected to the through-hole via in the picture in the original post. It passes through the same low pass capacitor and inductor that the onboard antenna uses (https://youtu....


0

Once connected to a network it will remain unless the network is shut down. This is normal behaviour for all computers. If you restart networking it MAY change, but even this can not be guaranteed.


1

Security is a complex subject, and I believe RPI.SE is not the right place to receive lecture on security. If this is the first time you touch security, you're overwhelmingly likely to hurt yourself by mistake. You may meet people with better knowledge on Security.SE and Crypto.SE, but they can't build a full solution on their own. I recommend OWASP ...


2

You can use ssh to connect to the RasPi and do your things. You can also use it as an ssh tunnel so you can use graphical user interfaces on the remote management computer to execute programs. Instead of an ssh tunnel you can also use a virtual private network using wireguard or OpenVPN. With the latter you are also able to have a bridged connection (with ...


Top 50 recent answers are included