Hot answers tagged

4

To disable a service means do not start it automatically on startup. It does not mean to disable its functionality. You always can start and stop it and it can be started by other services. That seems to be the case here. You can show dependencies with: rpi ~$ systemctl list-dependencies xrdp To disable a service completely you have to mask it: rpi ~$ ...


2

Here is what appears to be the client app. Seems to be free. Using a VNC viewer app such as this one rather than RDP is another alternative.


1

Disabling the wifi interface resolved the problem (well, at least it hasn't come back in a number of days :)).


1

Sigh. Turns out the problem was that my hosts file contained two entries for the Pi: 127.0.1.1 mycroft 10.0.0.5 mycroft When accessing the Pi by name, Remote Desktop defaulted to using the first entry, which of course failed, since it referred to the Windows machine's loopback address. Removing the first entry from /etc/hosts solved the ...


1

This is actually unrelated to the new hardware. Turns out that Stretch comes with RealVNC server installed. Stretch will run on either 3B or 3B+ systems. To use VNC, enable it in raspi-config and use a RealVNC client for access. But this conflicts with xrdp To fix the problem and make it work, simply remove RealVNC server. sudo apt-get update sudo ...


Only top voted, non community-wiki answers of a minimum length are eligible