2

I'm currently 100 miles away from said Raspberry Pi, and it's suddenly stopped listening for cloud connections through no intervention of my own. The client (running on windows) suddenly froze, like it often does, so I disconnected and tried to re-connect, only to find it refused. A couple of attempts later, the connection failed with a message: "VNC Server is not currently listening for Cloud connections."

Other internet-connected features on the pi were still working, although the only one I have access to has crashed due to (I assume) unfinished code changes.

Does anyone have any ideas why this happened, or how to remotely troubleshoot this with no portforwarding or SSH? I cannot try rebooting or doing anything that uses keyboard+mouse because I am 100 miles away and cannot return.

Clarification: The remote place IS my home and the only key-holders closer to my home than me are computer illiterate. At this point I think I might just be screwed, so if anyone could explain in the comments why VNC likes to commit death when I need it not to (maybe I need to have my pi automatically reboot daily?) that would still help.

2

if you are using RealVNC, then it may be a problem of their servers, since same happens to me to all my connections about 5 hours ago.

1
  • Unfortunately I'm still getting the same error now, but thanks for trying to help. – CrazySqueak Dec 27 '19 at 7:34
2

Right, so: It turned out my Pi decided that when I was 100 miles away was a great time to do the thing every Pi does when you need it the most, and completely lock up. I'll make use of @GraphMan's answer in an attempt to boost stability in case a network issue arises.

If you're having this problem yourself, make sure to look at the other answers on this post as it may not always be because of a complete lockup.

1

I would build and test a new SD Card with Buster at home and send it to the remote place so someone there can just swap the SD Card. Even better is to configure a complete second Raspberry Pi at home and send it to the remote place.

1
  • 1
    Unfortunately, my house is the remote place as I've now clarified in the question. Thanks for trying to help. – CrazySqueak Dec 28 '19 at 8:37
1

I have the same problem, and I don’t think it is the RealVNC servers, but rather the WiFi connection dropping and not restarting.

I have a 3 x rpi4 cluster and a single rpi4 running a python routine to monitor a wine cabinet. RealVNC seems to go down somewhat randomly on the four rpis, but much less frequently on the one running the python routine. I know RealVNC is up, because I can reach the other 3. I know the rpi4 itself is still running as I can ssh to it via a wired connection (all the rpi4s are on both WiFi and a separate hardwired Ethernet subnet via an independent router).

I have been troubleshooting this for a couple of months, and don’t yet have a definitive answer. I suspect it is due to instability in the WiFi daemon in Raspbian Buster, as the hardwired connection never drops. (I am running a Velops mesh system with reserved WiFi IP addresses for each pi).

So...my suggestion is to connect your rpi to your router by cable, or to run 1-2 backup rpi (could use zero’s for this) on a cheap Ethernet hub so you can reboot if one goes down. I also run a cron job and script to check if the WiFi is down and reconnect. This seems to help, but it occasionally goes down.

I know that does not help right now if you can’t VNC or SSH into your system. Sorry.

UPDATE: I have connected four rpi4s to a hub, and the hub uplink port with a wired connection to a Linksys Velop satellite node. No network issues for a continuous period of 70 days.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.