0

I'm new to the CM3+ module, but I've worked extensively with other RPi products.

I'm currently trying to implement my own FT5336 driver, but I'm having some slight problems, as the "Gesture" register address always returns 0.

I'm not the only person with that problem, as I've noticed that other people have had problems with this exact touch controller as well. It has been suggested that I contact the manufacturer, but they require information about the business and their direct contact information probably isn't meant for troubleshooting or support. At first I thought that I was doing something wrong and was supposed to write/send a command to the chip before reading the gesture, but after looking at other drivers, all they do is read.

Now I'm not sure if this is even the correct place to post this, if it isn't please let me know, so I can move it somewhere else.

My setup:

  • CM3+
  • Wondershare Compute Module IO Board Plus
  • Capacitive touch screen with FT5336 controller connected over DSI and I2C(-11?) (pins 28 and 29)
1

I have the same problem. I cannot have a reading for the gestures no matter what I do!!

side note though, I changed the mode of the interrupt from trigger to polling and it is much better to have an interrupt that only triggers the isr on falling edge and rising edge(when the touch start and the touch ends) and in between you can read via I2c as mush as you need and you have full control.

Things that just doesn't work with me so far:

  1. Gestures
  2. touch point weight(touch pressure)
  3. touch point Area

let me know if you have an update or if you figured out the gesture problem.

8
  • We've figured out that Wondershare has sent us a chip without gesture support, so we changed it for a different one. Our Wondershare did have a register for touch point area. – MG lolenstine Mar 13 at 16:22
  • Oh, OK. So they actually ship some of these without having the feature!! – Ahmed Mar 13 at 16:30
  • Sadly yeah, if I remember correctly, registers for gestures weren't saving any settings I've set. Try doing the same and check if it's the case with you as well. – MG lolenstine Mar 13 at 17:17
  • Just tried to set all the registers for min distance and max offsite and all of them are set correctly(I read them after to verify). are there any more settings I should apply ? Since you managed to make it work could you share with me the settings you used on the working project?.. and also I'm curious to know when do you read the gesture, after the touch points are lift up ?.. or is the gesture ID could be red before that ? – Ahmed Mar 13 at 18:40
  • 1
    Thank you, really appreciate your help. whenever you have time and could dig out anything I would be grateful :) – Ahmed Mar 13 at 22:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.