0

I'm using the same PCM5102A DAC board on a Pi B Rev2 as in this blog post with software configured as per this post, connected in the same way. The audio playback is slow but otherwise of good quality.

Audio plays at the correct speed from the builtin audio port, when configured that way.

I have since tried again with a different breakout board, again for a PCM5102A, but experienced the same problem. The problem remains whether or not I overclock the pi.

I haven't found anyone else on the internet reporting this problem - what am I missing? Is this a driver issue because for some reason the hifiberry-dac overlay isn't appropriate, or is it a hardware limitation of the Pi 1?

1

I've found this post in struggling with the slow playback on one of my Rpi3B. And your solution just worked! Thanks!!

Then I googled and found the reason as you did. Thanks again.

Temporary: sudo systemctl disable pigpiod

Permanently: Edit /etc/systemd/system/pigpiod.service.d/public.conf as including pigpiod -t 0, then reboot.

Effective for Rpi3B/Stretch and Rpi4B/Buster.

0

The answer turned out to be that pigpiod was using one of the Pi's PCM channels, also used by the DAC. Disabling pigpiod with sudo systemctl disable pigpiod solved the problem, but it should also be possible to get pigpiod to use the PWM instead: see http://abyz.me.uk/rpi/pigpio/pigpiod.html for more information.

It was clear from the Internet that pigpiod with its default settings was not compatible with I2S when searching "pigpiod i2s not working" or similar, but I didn't find anywhere citing pigpiod when searching for causes of slow playback from an I2S DAC.

This problem might affect other versions of the Pi. Hopefully the several months it took me to come by this obvious answer might help someone else!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.