1

I tried to run the command to test if my device supports monitor mode,

airmon-ng start wlan-0

and this is the error is received,

ERROR adding monitor mode interface: command failed: Operation not supported (-95)

Apparently i am using a raspberry pi 4 model B for network scanning but it does not support monitor mode for this to happen, can anyone suggest me a way to have this mode on my device.

1
  • Off the top of my head: did you try running that with sudo, and is your interface really called wlan-0, and not wlan0? And then, there's always the option to buy a USB stick with a recommended chipset. Mar 3 at 16:46
3

If you look at the chip configuration on the RasPi with:

rpi ~$ iw list
Wiphy phy0
--- snip ---
    Supported interface modes:
             * IBSS
             * managed
             * AP
             * P2P-client
             * P2P-GO
             * P2P-device
--- snap ---

There is no monitor mode available, so you are out of luck with sniffing WiFi networks with a Raspberry Pi. There is a project nexmon on github that patches the WiFi firmware to make the monitor mode available. Seems not to be an easy task but you may have a look at it.

For some additional information you can also look at Enable monitor mode.

You may consider to purchase an additional USB/WiFi dongle that supports monitor mode.

0

I ran the aircrack program with my Raspberry Pi 4 8 gig approximately 1 week ago. I had no issues setting the internal WiFi interface into monitor mode.

Then again I was running Kali on the pi hardware. Although that shouldn't matter I don't think.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.