I'm roughly following this tutorial but with cygwin instead:

I use cygwin for another project so I would rather not switch to another GNU tools package.

I have:

  • Installed cmake, gcc, make via cygwin
  • Installed git via Git for Windows
  • Installed rpi pico sdk
  • Configured and tested environment variables (looks ok to me)
  • Created the makefiles using cmake -G "Unix Makefiles" ..

When I cd into the blink directory and try to make, I eventually get this:

Scanning dependencies of target bs2_default
[  0%] Building ASM object pico-sdk/src/rp2_common/boot_stage2/CMakeFiles/bs2_default.dir/compile_time_choice.S.obj
cc1.exe: fatal error: /cygdrive/c/VSARM/picosdk/src/rp2_common/boot_stage2/compile_time_choice.S: No such file or directory
compilation terminated.

What am I missing?

I've tried this with cmake 3.20.0 and 3.23.2. In between, I deleted the build folder and recreated it. The result was the same in both cases.

1 Answer 1


I am having similar issues. I think the problem is that we're calling the arm compiler using the cygwin file path, but the compiler only understands MSDOS paths. I ended up installing minGW64 and then setting up an alternate universe (ok, just a alternate path) that included minGW64 and excluded Cygwin.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.