2

I'm trying to ssh from my mac to my pi but when ssh'ing terminal returns "operation timed out".

ifconfig on the Pi returns 192.168.1.10, but when I ping to that IP I get 100% packet loss.

I've tried rebooting, connecting the ethernet cable directly to my mac (with internet sharing on), the ethernet cable connected to the (time machine) router, ifup wlan0 (returns interface already configured), inside /etc/network/interfaces set up static ip address (192.168.1.10)

nano sbin/ifconfig returns a bunch of weird symbols.

I don't have internet on the RPi so apt-get update doesn't work.

Could there be something wrong with firewall? And if so, where can I change these settings?

  • Are you connected to the same router that you plug in your RPi? – GonacFaria Apr 10 '14 at 11:55
  • Yes, my mac is wirelessly connected to my time machine router and my RPi ethernet cable is plugged in to that same router. Also tried connecting to my mac directly (should also work with internet sharing on) – user14122 Apr 10 '14 at 12:12
  • Can you access the time machine router control panel over the internet? That would help, as we could attempt to turn on port forwarding. That might be an issue, might not. – RPiAwesomeness Apr 10 '14 at 12:24
  • 1
    time capsule IP: 192.168.0.212 sudo dhclient on rpi returns "file exists" How can i acces the port forwarding? airport utility gives limited info about time capsule – user14122 Apr 10 '14 at 12:41
  • 1
    yes ofcourse, as my mac is using it as a router. Problem solved by removing static ip adress, plugging into router and reboot. – user14122 Apr 10 '14 at 14:07
3

From your post and comments:

... time capsule IP: 192.168.0.212

... set up static ip address (192.168.1.10)

Your RPi and your Time Capsule are not in the same network. Take a look.

UPDATE:

So, you would only need to change one or another IP. I didn't mention, as it was implicit in my observation: " ... not in the same network". So, changing Time Capsule to 192.168.1.212 or RPi to 192.168.0.10 would do the trick.

But, in case you would like a more complete solution, you can download this wicd-1.7.2.4 package (from GitHub) in another computer with internet connection, copy it to RPi root (using your console interface and a pendrive to transfer) and doing a:

cd /    
sudo tar -zxvf wicd-1.7.2.4.linux-armv6l.tar.gz

Or, if you've gotten a connection with your Rpi, you could also try installing and using wicd:

sudo apt-get install wicd-curses

Now, you are ready to start:

sudo wicd-curses

You will get a list of wireless networks, found by RPi, and your wired network.

Using wicd with Raspberry Pi

Then, you can select your wifi or wired network. Just highlight it with arrow keys and press right arrow key to edit its properties.

When you’re done, just press F10 to save it. It should connect!

  • thank you for your answer, it sounds like good solution but the thing is, I don't have internet on my RPi. sudo apt-get won't work.. – user14122 Apr 10 '14 at 13:10
  • 1
    I've just updated! – Adrian Nicolaiev Apr 10 '14 at 17:27
2

If your RPi IP is 192.168.1.10 and the Time Capsule is 192.168.0.212, they are in different Networks. and if you've set your RPi with a static IP make sure it is correct, just enter the following command,

cat /etc/network/interfaces

and look for the line

iface eth0 inet static

Under it you have the address, correct it (in this case 192.168.0.10) and save. Reboot the device and you are good to go.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.