I can't see any files whose names are composed entirely of Chinese characters on my Raspbmc menus. If there is a mixutre of Chinese and ASCII characters, I can see only the ASCII characters in the file name. I've searched but I can't find any information about how to enable Chinese language support.

  • It's not really a pi specific question, you might have better luck with this on unix/linux SE. Perhaps ask to have it migrated. Raspbmc is a minimal Debian Distribution. – Tyson Aug 24 '14 at 4:32
  • Raspbmc is based on debian, so why not just pull language support from there? packages.debian.org/stable/localization – j0h Aug 24 '14 at 14:15
  • It's not a problem with Debian's filesystem. It's a problem with the menus used to select media files. The XBMC interface is lacking Chinese support and I'm not sure how to enable it. – Reed G. Law Aug 25 '14 at 1:44
up vote 1 down vote accepted

From http://immigrationroad.com/blog/how-to-watch-chinese-tv-online-using-xbmc/ :

Display XBMC Menus in Chinese

To make XBMC display Chinese characters correctly, you will need to install fonts and change several settings.

  • Go to XBMC.org and download the font: DejaVuSans+DriodSansFallback.ttf;
  • Change the file name to arial.ttf;
  • Go to (your XBMC installation folder)/XBMC/media/Fonts/. For example, it may be C:/Program Files/XBMC/media/Fonts/;
  • There should be a file already called arial.ttf. Change the file name to something like arial-original in case you will need it later on;
  • Now copy and paste your downloaded arial.ttf to the Fonts folder;
  • Go to XBMC – Home – System – Settings – Appearance;
  • Under Skin – Fonts, click the up/down arrow to change the setting to “Arial based”;
  • Under International – Language, click the up/down arrow to select Chinese (Simple);
  • Under International – Character Set, click the up/down arrow to select Chinese Simplified (GBK);
  • Your XBMC should now be displaying Chinese characters properly;

This worked for me but I changed the font directory to /usr/share/fonts/truetype.

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.