10

Trying to connect my new Raspi to the internet for the first time via a cross-over to a bridged connection with my laptop's wi-fi.

The Raspi browser works for internal network webservers but won't receive anything from the WAN using either URL or ip address. Get a name resolution failure and a fail to load page.

I'm thinking it must be router related as it only fails if going through the gateway router.

Any ideas what the issue might be and how to resolve it?

  • What's the output of the following commands? ip addr show ip route show cat /etc/resolv.conf I think your dhcp server has either not send the correct dns servers or routers to external networks. Did you try pinging a external server? ping -c 4 8.8.8.8 (This is a DNS Server from google). – teissler Jan 3 '13 at 7:13
  • 1
    Try running traceroute 8.8.8.8. Since external ping fails, we're interested in first few results. – AndrejaKo Jan 3 '13 at 9:08
  • Problem is resolved. I rebooted the laptop this morning and the router. Re-instated the bridge in the laptop and suddenly things started to work. – Chef Flambe Jan 3 '13 at 18:51
5

Try the following:

sudo nano /etc/network/interfaces

Then on the interfaces file you should have something like:

iface wlan0

Insert a new line exactly after that one with your DNS server (I will use google's for the example):

dns-nameservers 8.8.8.8 8.8.4.4

Exactly like that and just reboot your pi via:

sudo reboot

That fixed mine, I hope it gets yours going!

Edit:

I also changed the content of the file resolv.conf on the /etc/ directory:

sudo nano /etc/resolv.conf

In which you will see something like:

domain gateway.2wire.net
search gateway.2wire.net
nameserver 192.168.1.1

Change the nameserver IP to whatever your DNS is.

  • 1
    this solution solve my problem after several hours crashing my head with it – rdiaz82 Mar 30 '16 at 23:08
0

Thanks for all the help.

I ended up picking up the Make Mag book on the RaspPi and followed the walk-thru on the configuration of the WiFi. Have no idea what I was doing but it seemed to get it working without any hassle and I did it in under 15minutes.

I'm thinking it was a problem in the interfaces file that I had done changes to to make it a static IP. I had read a couple conflicting articles and I think I picked the wrong one...Ooops.

Anyway, works great now and I've been playing with the Gert board so life is good.

  • 3
    Can you share the details of that walk through? – Andre M Nov 28 '16 at 19:01
  • Yeah, details are nice, so when others come looking with the same problem, your answer might actually be of help. – eidylon Jan 18 '18 at 20:52
  • @eidylon - you realize this is a 5 year old post, right? – Chef Flambe Jan 20 '18 at 1:19
0
  1. I modified a file using the command below:

    sudo nano /etc/dhcpcd.conf
    
  2. uncommented this line:

    static domain_name_servers=192.168.0.1.....blah blah blah

    it is in the third block from the bottom, seems to have worked

  • Can you please show the code that worked? – SDsolar Jun 28 '18 at 22:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.