0

I have followed the latest guide about changing the /etc/dhcpcd.conf file, and successfully set a static ip address, but then I can't reach the pi through ssh or a browser (it's a server). Any body else experience this?

  • Can you please post a link to the guide you followed? I set my static IP address by updating /etc/network/interfaces. Can you ping the static IP address up configured? – HeatfanJohn Mar 18 '16 at 0:59
  • Why do you have to set a static address on the RPi - why not just tell your router to assign a fixed address to the MAC associated with your RPi? – SlySven Mar 18 '16 at 19:16
  • I can give you the post that took me there. raspberrypi.stackexchange.com/questions/37916/… – Thomas Wurdinger Mar 19 '16 at 14:50
  • I'm not knowledgeable enough yet to assign the fixed address, still learning – Thomas Wurdinger Mar 19 '16 at 14:51
2

As you know, networking configuration in Raspbian Jessie has moved to /etc/dhcpcd.conf .

Try the following steps to troubleshoot the issue:

  1. Restart networking:

sudo ifdown eth0 && sudo ifup eth0

  1. Check if your interface is configured:

ifconfig

Does eth0 have the address you specified?

  1. Did you format the address in /etc/dhcpcd.conf with CIDR subnet mask notation, and does the subnet mask match your local area network (/24 is equivalent to 255.255.255.0):

static ip_address=10.0.1.59/24

?

  • O.k. I tried number 1 with no luck. Number 2 is a yes (I have to plug in a monitor and keyboard to access the config files. and the address I specified in the dhcpd.conf file was : 192.168.1.1/24. On a side note,( I am not trying to correct you - I promise) I may have a newer version of jessie, but my file is named /etc/dhcpcd. I don't have anything with the shorter name. :( – Thomas Wurdinger Mar 18 '16 at 11:34
  • Hello, it's working. I tried 192.168.0.201/24 instead of 192.168.1.1/24 and it worked perfectly. I don't know why, though. Maybe it has to do with them being on different subnets? Anywho, thank you for your help! – Thomas Wurdinger Mar 18 '16 at 11:42
  • Apologies, you are correct, my memory failed me. Answer has beed edited. – medbot Mar 18 '16 at 19:13
  • 1
    Regarding your fix, it did not work prior because network hosts on different subnets can not reach each other without a router between. – medbot Mar 18 '16 at 19:14
  • o.k. that seems legit – Thomas Wurdinger Mar 19 '16 at 14:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.