0

I have a DVI to HDMI cable that is connecting a TV to my Raspberry Pi 2. I am just trying to hook up the Raspberry Pi 2 so I can stream videos through OSMC. I have no background on coding or how to work the Raspberry Pi 2, so if you could help me out with a step-by-step guide, that'd be great.

The TV outputs the video, but there is no sound. I tried going to Settings->System->Audio Output and changed the Audio Output Device to all 4 options, but none work. Could someone please help me out? Please let me know if you need any additional information.

1

Digital sound, as included in the HDMI standard and output put the Pi is not included in the DVI standard which is only "designed to transmit uncompressed digital video". All DVI connectors that include audio are non-standard.

Simple way here: using HDMI-to-DVI for the video only and the 3.5 mm analog jack to provide the audio signal (and feed that to an analog audio input at your TV - if it has one). Requires to force analog audio output though, see here how to do that.

  • Comments are not for extended discussion; this conversation has been moved to chat. – Ghanima May 21 '16 at 8:51
  • @R.Sam, check page 40 and 41. It reads that you should connect to the green audio jack when using either analog video in or DVI video in. To me that sounds like it should work. Is this the jack you used before? – Ghanima May 21 '16 at 8:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.