1

I installed motion to do live streaming with my webcam. Before this, I have tested the webcam with taking photo, it's working. I have configured the motion.conf and set stream_localhost to off.

When I access the ipaddress:8081, google chrome show site can't be reached. ERR_CONNECTION_REFUSED

Please note that i have a wordpress site on the ipaddress port 80 (default). Is that the cause that i can't play live stream?

Please assist, thank you.

1

Be sure that motion service is running. If you run it as service (daemon) you can check it with following command:

sudo service --status-all

If you see a minus [-] sign in front of motion you must first start it with

sudo service motion start

Then you may see the streaming video.

2
  • Hi, i have check the running service, but motion is not in the list. I have config the file etc/default/motion to set daemon to yes and start the service. Any idea? – Jeff Pang Nov 14 '16 at 5:52
  • If motion is not in the list, then it is not running. Can you post your config file? My motion.conf file is in /etc/motion/motion.conf. Is there anything in log file /var/log/motion.log or system default logfile? – Mubin Icyer Nov 14 '16 at 9:06
1

probably just this parameter to set off in motion.conf file to allow external connections :

# Restrict stream connections to localhost only (default: on)
stream_localhost off
1
  • Thank you very much – tdmiller Feb 26 '20 at 21:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.