2

I'm visiting my relative's house during this holiday. I bought my Raspberry Pi 3 and other gadgets. The Pi is a media server and a wifi router to share the internet in the guest room.

Everything is working, but I noticed syslog kept recording the following messages in the /var/log/syslog on every few seconds. Following is just an excerpt but the actual number of the records was nearly 100k since the Christmas Eve.

...
Dec 30 20:50:20 RPi-Dev dhcpcd[591]: wlan0: fe80::4270:9ff:fef7:74d7 router available
Dec 30 20:50:23 RPi-Dev dhcpcd[591]: wlan0: fe80::4270:9ff:fef7:74d7 router available
Dec 30 20:50:27 RPi-Dev dhcpcd[591]: wlan0: fe80::4270:9ff:fef7:74d7 router available
Dec 30 20:50:32 RPi-Dev dhcpcd[591]: wlan0: fe80::4270:9ff:fef7:74d7 router available
Dec 30 20:50:41 RPi-Dev dhcpcd[591]: wlan0: fe80::4270:9ff:fef7:74d7 router available
..

I could find a similiar problem here and added a setting that suppresses the message in the /etc/rsyslog.conf as following.

:msg, contains, "router available" ~

Now, rsyslogstopped recording the message. However, I'm not comfortable with it, and I'd like to fix the cause. Could someone explain to me what might be causing it, what I should check and how I can fix it?

2

Edit /etc/dhcpcd.conf and add a single line to the bottom of the file "noipv6rs" - that does seem to stop the lot by stopping IPV6 route solicitations. I've added nodhcp6 as well to be sure - this alone doesn't stop dhcpcd reporting a friendly, helpful router...

1
  • So should you add that line to the file and reset the RPi? Or does it have an immediate effect?
    – xtian777x
    May 13 '17 at 18:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.