0

I've recently revived my Raspberry Pi B, which is not nearly as powerful as the 3's that are out now. I've resorted to using it as a media hub for all of my hard drives and large flash drives as network shares. Because neither my desktop nor my surface have disk drives or floppy drives, I have attached a floppy drive via USB and plan to do the same with my USB CD drive as soon as it arrives however I have already had a problem with the floppy drive as I can read files but I can't write to them. Here are my following configurations for the fstab and samba configuration files:

Samba:

Output omitted

[FLDRIVE] writeable = yes path = /media/fldrive

Fstab:

/dev/sdb1 /media/fldrive vfat defaults 0 0

Any ideas?

Thanks!

Edit: Yes, the floppy disk is set to read/write

1

Try force user

Someone in an archived Red Hat mailing list was having the same issue:

While I am able to share /mnt/floppy, and it appears to work for read access, I am unable to give write permissions to /dev/fd0 (mounted as /mnt/floppy) to any Samba users.

The solution was the force user option in samba.conf:

On 1 Jul 2003 at 22:00, Steeve McCauley wrote:

You'll want to play with the

force user

force group

force create mode

force directory mode

options in smb.conf. "man 5 smb.conf" for details.

Thanks Steeve, force user did the trick. I should have tried that myself, but for some obscure reason I was concentrating on playing around with the permissions of /mnt/floppy, mount and fstab.

For the record, the shard of smb.conf follows:

# Floppy_drive [floppy]
comment = floppy
path = /mnt/floppy
read only = no
public = yes
force user = root

Russell

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.