1

I'm running kivy on a Raspberry Pi. I accepted that apparently you can't get around the fullscreen, but I can't get the cursor to show either. I tried by adding

touchring = show_cursor=true

to the [modules]-section of config.ini (in my home directory and the root directory), but it's not working. In the [graphics]-section

show_cursor = 1 

is set as well, but nothing changes. Somebody know another solution?

1
  • Abandoned post by Unregistered user.
    – Milliways
    Jun 11, 2023 at 6:24

1 Answer 1

0

For others, who might like me be bloody beginners on Linux/Pi/Python, and can't find the cursor.py file:

To simply add a cursor in your kivy-apps, add this to the end of the config.ini in ~./.kivy (below the [modules] thingy):

cursor=1

There's obviously many different options you can additionally change, like the cursortexture and whatnot. But for me it was sufficient to finally see any cursor at all, so i didn't really bother about those other options.

If you can't find the config.ini file run the following code:

import kivy

print(kivy.kivy_home_dir)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.