0

I have an LCD from a Chonese manufacturer. 12.3", resolution is 1920x720 pixels. When I set the following in the config.txt file I get some white stuff at the bottom of the screen. Any ideas why?

This is my config.txt file contents:

hdmi_force_hotplug=1
hdmi_group=2 
hdmi_mode=1 
hdmi_mode=87 
hdmi_cvt 1920 720 60 6 0 0 0

Here is the image of what the output looks like: Here is the image of what the output looks like:

The manufacturer also has provided the following advising to set the HDMI to, but I'm unsure of how to set this up in the config.txt file.

#define   Vclk_MHZ   132
#define   LCD_XSIZE   1920
#define   LCD_YSIZE   720
#define ADJHIGHT    LCD_YSIZE

#define   LCD_BPP      16

#define FRAME_RATE   60

#define   LCD_ROTATE   0


#define  HBPD       110
#define  HFPD        8
#define  HSPW       8

#define  VBPD        10
#define  VFPD        10
#define  VSPW        4

Any help is appreciated. Thank you.

1

I'm pretty sure we have the same screen (CDTech 12.3 inch 1920x720)

I had the same issue when I typed following into the config.txt file:

hdmi_cvt=1920 720 60 0 0 0 0

However, it turns out the pi doesn't properly adjust the pixel frequency of the display. You might need to do some tuning, but the process should more or less be the same. In your config.txt file, add this line above the "hdmi_group" property:

hdmi_ignore_edid=0xa5000080

This will disable the pi from automatically assuming an approximate pixel frequency, which is likely causing our issue. Next, toward the end of the config.txt file, add this line:

hdmi_timings=1920 0 88 44 148 720 0 4 5 36 0 0 0 60 0 109244953 1

I've obtained these values by running an EDID scan (not entirely sure what that even means lol) and using this webpage, which is a great resource: https://www.raspberrypi.org/forums/viewtopic.php?t=24679

The second to last number might be specific to your module (I think), but it doesn't hurt to try the number I posted. This is the pixel frequency.

| improve this answer | |
0

If you happen to be trying this with a Raspberry Pi 4 using Balena to deploy a Docker container, try writing these settings to the config.txt file before first boot. Note the frequency is different to the answer above, 100980000 instead of 109244953.

hdmi_ignore_edid=0xa5000080
hdmi_group=2
hdmi_mode=87
disable_overscan=1
hdmi_timings=1920 0 88 44 148 720 0 4 5 36 0 0 0 60 0 100980000 1

I found that value by running xrandr -q on a stock Raspbian image.

Screen 0: minimum 320 x 200, current 720 x 1920, maximum 7680 x 7680
HDMI-1 connected primary 720x1920+0+0 left (normal left inverted right x axis y axis) 0mm x 0mm
   1920x1080     60.00  
   1024x768      60.00  
   800x600       60.32    56.25  
   848x480       60.00  
   640x480       59.94  
  1920x720 (0x42) 100.980MHz +HSync +VSync
        h: width  1920 start 2008 end 2052 total 2200 skew    0 clock  45.90KHz
        v: height  720 start  724 end  729 total  765           clock  60.00Hz

Other ways I found to set this without touching the config.txt:

$ xrandr --newmode "1920x720_60.00"  100.98  1920 2008 2052 2200  720 724 729 765  +HSync +Vsync
$ xrandr --addmode HDMI-1 "1920x720_60.00"
$ xrandr --output HDMI-1 --mode "1920x720_60.00"

or

$ vcgencmd hdmi_timings 1920 0 88 44 148 720 0 4 5 36 0 0 0 60 0 100980000 1
$ tvservice -e 'DMT 87'
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.