3

I have a Raspberry Pi 3 running the most recent Raspbian distro.

I've installed the most recent go, from the prebuilt package and have it on my path:

$ go version
go version go1.9 linux/arm

However, when I try to install keybase:

$ go get github.com/keybase/client/go/keybase
/usr/local/go/pkg/tool/linux_arm/link: running gcc failed: fork/exec /usr/bin/gcc: cannot allocate memory

I've looked around and tried a few different things, like lowering my ulimit, to no avail. Any clue what I can do to install the most recent version of keybase?

2

create a swap file with 4 GB of space: This was my problum when installing docker i had to create a swap file and it worked same error code, so let me know if this works!

Source: This Post

Raspbian uses dphys-swapfile, which is a swap-file based solution instead of the "standard" swap-partition based solution. It is much easier to change the size of the swap.

The configuration file is:

/etc/dphys-swapfile 

The content is very simple. By default my Raspbian has 100MB of swap:

CONF_SWAPSIZE=100

If you want to change the size, you need to modify the number and restart dphys-swapfile:

/etc/init.d/dphys-swapfile stop
/etc/init.d/dphys-swapfile start

Edit: On Raspbian the default location is /var/swap, which is (of course) located on the SD card. I think it is a bad idea, so I would like to point out, that the /etc/dphys-swapfile can have the following option too:

CONF_SWAPFILE=/media/btsync/swapfile

I only problem with it, the usb storage is automounted, so a potential race here (automount vs. swapon)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.