1

I'm trying to set up my Raspberry Pi with a 64GB micro-SD card using the image file 2018-04-18-raspbian-stretch-lite.

Every time I try to update or install software on the card, the system gives me the following error message:

dpkg: unrecoverable fatal error, aborting:
unable to sync directory '/var/lib/dpkg/updates/': Input/output error
E: Sub-process /usr/bin/dpkg returned an error code (2)
W: Problem unlinking the file /var/cache/apt/pkgcache.bin - pkgDPkgPM::Go (30: Read-only file system)

When running the program out of ssh and directly into my tv, I also get the following line:

EXT4-fe error (device mmcblk0p7): ext4_journal_check_start:61: Detected aborted journal
EXT4-fe (mmcblk0p7): Remounting filesystem read-only

The system then refuses to run any more programs and I cannot access the system again after I log out. (I normally access my Raspberry Pi via SSH.) I've checked the filesystem on the card, as per this article, and Disk Utility is telling me the card is FAT32, so that doesn't seem to be the issue; and besides the article says the card shouldn't even boot up the first time if I was using the wrong filesystem.

I have tried installing Raspbian on two different 64GB cards now and have got the same result on both. Additionally, I tried doing the same thing on a 16GB card and it worked normally.

The process which I normally take is as follows.

  1. I use Etcher in order to flash the image onto the SD card.
  2. I then add a blank ssh file so that I can access it from ssh without a monitor.
  3. I run sudo apt update && sudo apt upgrade, which produces the error in the middle of the install phase. There doesn't seem to be any particular package that sets this off.

I have followed these steps with 16GB cards and have got no such error. I have also tried to install Raspbian using NOOBS (Both full and Minimal versions) and have got the same result.

  • You are asking us to guess what you have done. That is a waste of our time. Please explain each of the steps you have taken from a blank SD card to the error seen above. – joan Aug 25 '18 at 10:50
  • I have Raspbian running on 64GB cards on a Raspberry Pi Model 3B+, so assuming similar hardware, the size of the card is not the problem. Your question says you're running Raspbian Stretch Lite, but the article you point to is about using NOOBS. For what it's worth, my boot partition is vfat and the root partition is ext4. As @joan has said, we need to know the steps you've taken. – Bob Brown Aug 25 '18 at 12:03
  • 2
    I have added more details to the question. Hopefully this will describe the problem better. – Limisios Aug 25 '18 at 20:07
  • You get an error message "EXT4-fe (mmcblk0p7): Remounting filesystem read-only". If you flashed Raspbian Stretch Lite 2018-04-18 as you said you only have /dev/mmcblk0p1 (fat32 boot partition) and /dev/mmcblk0p2 (ext4 root partition) but never mmcblk0p7 as stated in the error message. Seems there is something wrong with the image you have flashed. – Ingo Aug 25 '18 at 23:24
  • That would be really strange as I use the same image whenever I flash a Raspberry Pi and I only have problems on 64GB cards. I've flashed and re-flashed quite a few 8GB and 16GB cards with the same image and have never had this problem. – Limisios Aug 26 '18 at 12:31
0

I believe that the largest sized SD card supported on the Raspberry Pi 3 is 32 GB. Larger cards are allowed on the 3b+

The other possibility is that the card is a forgery and only looks like it's 64GB.

  • 1
    I checked the version of my Raspberry Pi and it is indeed only a 3B and not a 3B+. I've found other answer that links to a wiki that lists SD cards that might be faulty, and my SD card does appear on that list as not ok. (Lexar UHS-I U1 LSDMI64GB1NL300A 12876361) Does that list only apply to <=3B or do you think I would get the same issue if I purchased a 3B+? – Limisios Aug 25 '18 at 21:26
0

After a lot of trial and error I have concluded that it was the particular model of Lexar MicroSD card that I was using. I've decided to go with a SanDisk 32GB MicroSD card and that works perfectly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.