0

i'm trying to install a package using the terminal specifically

sudo apt-get install sysbench

but i get the following error

The following packages have unmet dependencies:
 chromium-browser-l10n : Depends: chromium-browser (>= 65.0.3325.181-0+rpt4) but 56.0.2924.84-0ubuntu0.14.04.1.1011 is to be installed
 rpi-chromium-mods : Depends: chromium-browser (>= 65) but 56.0.2924.84-0ubuntu0.14.04.1.1011 is to be installed
 sysbench : Depends: libmariadbclient18 (>= 5.5.36) but it is not going to be installed

I have an older version of chromium because I need widevine. Is it possible to install packages without upgrading chromium to 65?

  • 1
    What OS + version do you run? On Standard RPF Raspbian Stretch I get Chromium 65 installed without problems. It looks to me that your apt sources are interfering. Add all the apt sources to your question (/etc/apt/sources.list and all list files in /etc/apt/sources.list.d) – Dirk Dec 8 '18 at 9:35
  • try using aptitude or synaptic they're both better at resolving those package co-requisites and pre-requisites. You may need to install those with apt install synaptic aptitude – Dougie Dec 8 '18 at 9:51
  • I don't know much about widevine, can't it be made to work with chromium 65 as well? If not, then do you need chromium-browser-l10n and rpi-chromium-mods? If not, remove them, since they are what is blocking your sysbench install. Also how did you get those two installed without chromium 65? – T. M. Dec 8 '18 at 14:40
  • Hi thanks for replying @Dougie i am unable to install any packages so i cant use aptitude or synaptic because i cant install them. – john smith Dec 8 '18 at 18:45
  • @T.M. widevine sadly only works on 56 and not newer versions so i had to downgrade in order to use it, i am not sure how to remove chromium-browser-l10n and rpi-chromium-mods, and would removing them cause any problems with my current chromium build? – john smith Dec 8 '18 at 18:46
0

If that's what you really want, then

sudo apt-get remove chromium-browser-l10n rpi-chromium-mods scratch2

will remove the two broken packages. And should allow you to install other packages that don't depend on chromium. Oddly you'll lose scratch2 also since that depends on rpi-chromium-mods.

I feel like there has to be a better way to have a different version of chromium, but pinning is a good way to break a lot of things too.

  • i cant remove them as i get this error You might want to run 'apt --fix-broken install' to correct these. The following packages have unmet dependencies: scratch2 : Depends: rpi-chromium-mods but it is not going to be installed E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution). apt --fix-broken install' forces me to install the newer chromium build which i dont want. – john smith Dec 9 '18 at 3:24
  • If you don’t need scratch2 then try adding that to the list of packages to remove. Short version is running different versions of software isn’t very easy. – T. M. Dec 9 '18 at 14:07
  • @john-smith glad it worked. If you click on answered it helps to close things out of SE I think. – T. M. Dec 13 '18 at 21:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.