1

How do I display Raspberry Pi 3 screen onto laptop?

I followed instructions to set up Raspberry Pi here, https://projects.raspberrypi.org/en/projects/raspberry-pi-setting-up

I got up to here, https://projects.raspberrypi.org/en/projects/raspberry-pi-setting-up/5. When I plugged in power, I did not see three raspberries on screen.

Here is what I did so far:

  1. Formatted SD card and copied extracted NOOB files to SD card

  2. Plugged in power cord to Raspberry Pi 3 (red light is on)

  3. Connected HDMI cable from Raspberry Pi to Windows 10 Laptop

  4. Connected Ethernet cable from Raspberry Pi to Windows 10 Laptop (green light is on)

Now, I am following instructions here, https://www.instructables.com/id/How-to-connect-raspberry-pi-to-laptop-display/

I got up to the part,

For sharing internet to multiple users over Ethernet, go to Network and Sharing Center. Then click on the WiFi network: Click on Properties (shown below), then go to Sharing and click on “Allow other network users to connect”.

How do I change Network Connection to Local Area Network? Is this even required in my case? This is where the confusion starts.

Then I proceed to find IP address by going to command prompt on Laptop.

Ethernet IP is 192.168.137.1. I can ping it, but when I type arp -a I get No ARP Entries Found.

Here is how my network looks

enter image description here

Can you guide in troubleshooting? Are there an easier set of instructions to follow? Please help!!!!!

Tried following, still no luck

Downloaded iTunes. Unzipped with 7Zip. Installed Bonjour 3

enter image description here

When I scan for IPs, I get this - I cannot ping any of these IP addresses

enter image description here

However when I ping raspberrypi.local, I get the following:

Pinging raspberrypi.local [fe80::fe78:f803:2dcb:3a78%17] with 32 bytes of data:
Reply from fe80::fe78:f803:2dcb:3a78%17: time<1ms
Reply from fe80::fe78:f803:2dcb:3a78%17: time<1ms
Reply from fe80::fe78:f803:2dcb:3a78%17: time<1ms
Reply from fe80::fe78:f803:2dcb:3a78%17: time<1ms

Ping statistics for fe80::fe78:f803:2dcb:3a78%17:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms

When I SSH (via Putty) to raspberrypi.local I get following error

enter image description here

  • If you're using noobs you'll need to set it up with an actual monitor to install an OS. To view the display on your laptop you'll need to setup a VNC server once you've installed raspian. The easiest way might be to flash raspian to the sd card and then you should be able to plug the ethernet cable in and connect it to your laptop. Plugging a hdmi cable directly from your pi to the laptop won't do anything as I doubt the laptop has a hdmi input only output the same as the pi. – rohtua Mar 28 at 18:48
  • @rohtua You mean connect Raspberry Pi to Sony Bravia (what we have) via HDMI? – Marium Mar 28 at 18:50
  • If Sony Bravia is your TV/physical monitor then yes. Plugging it directly into a laptop hdmi wont do anything as it's not an input just an output. – rohtua Mar 28 at 18:52
0

If there are some problems using NOOBS then I suggest to flash your favorite Raspbian image direct to the SD Card. Most of us do it because it is less error prone. How to do it look at Installing operating system images.

You wrote that you connected HDMI cable from Raspberry Pi to Windows 10 Laptop. This is not possible. Both HDMI ports are outputs. You have to connect a HDMI output to a HDMI input as you find on most modern monitor. So connect your RasPi to a monitor or a TV with HDMI input.

If you connected the RasPi to the MS Windows 10 laptop by ethernet you should be able to ping raspberrypi.mshome.com from the laptop. It's also possible to install Bonjour for MS Windows (some infos see also https://raspberrypi.stackexchange.com/a/94629/79866). Then you should be able to ping raspberrypi.local.

Make sure that ssh is enabled on the RasPi. You can do it by putting an empty file named ssh into the /boot directory with:

rpi ~$ sudo touch /boot/ssh

Then reboot.

  • I flashed the SD disk. Advanced IP Scanner shows raspberrypi.mshome.com, which I can ping. Which Bonjour for Windows do I download. I know it's related to networking but support.apple.com/downloads/bonjour%2520networking%2520windows does not show Networking – Marium Mar 29 at 0:46
  • @Marium Thanks for the info. I have updated the answer in the last paragraph. There you find a link to an accepted answer using Bonjour for Windows. @c0D3l0g1c confirmed in his comment, that it's working. If my answer help you a bit, it would be nice if you could accept it with a tick on tick on the left side. This will finish the question and show others that it has a solution. – Ingo Mar 29 at 10:04
  • Will try this in next few days.Once I'm successful I shall certainly give tick – Marium Mar 29 at 12:20
  • I updated question ….. tried and still no luck :-( – Marium Mar 30 at 16:07
  • @Marium As you wrote you can ping raspberrypy.local. So installing Bonjour for Windows is OK and the network is definitely reachable. You are doing something wrong with putty. With ssh you would do ssh pi@raspberrypi.local. Do you use user pi with putty? – Ingo Mar 30 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.