0

I am trying to run my raspberry pi by using putty but i keep getting network is unreachable. I have tryenter image description here run it on other device it was working well

  • 1
    How do you configure putty? What's the destination address? Please take the short Tour and visit the Help Center to get an idea how things work here. – Ingo Apr 22 at 19:33
  • if you are using port forwarding to reach the pi from outside your network, you cannot use that external address from inside your network, you should use the actual IP address of the pi. if this doesnt help, give us more information to work with. Are you on the same network when it works, when it doesnt? Can you ping it from the computer that wont connect via ssh? – Chad G Apr 22 at 21:55
-1

Have you activated the SSH Server on the Raspberry Pi? You can do so by going to the terminal and typing raspi-config -> Interfacing options -> SSH and selecting yes.

Why did you use the public IP address? Just use the local IP address to access your Raspberry Pi, unless you have port forwarding setup for your Raspberry Pi.

  • op said it worked from another machine, so ssh is enabled – Chad G Apr 22 at 21:53
  • thank you sir but I have finally fix it. it was due to the Ethernet setting on my computer// properties > sharing > tick the options – mo7d95 Apr 23 at 22:49
  • 1
    Glad you found a solution. You can answer your question and mark it as solved. – Sir Muffington Apr 24 at 9:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.