I run a headless Raspberry Pi 4 (4 GB) which is powered by the official USB-C power supply. I operate the Pi 4 (Raspbian Buster Lite) via the ssh protocol (putty) from a Windows machine.

I realized that the ssh connection sometimes feels unresponsive: typing on my keyboard will sometimes take up to two seconds to be displayed in the putty shell. I was able to solve the problem by switching from a wired Ethernet connection to a wireless WiFi connection on the Pi 4.

Additionally I tried pinging the Pi 4 from a Windows machine in the same network via the ping command:

  • Ethernet: 87/100 packets were received (13% loss). (requests did time out)
  • WiFi: 100/100 packets were received (0% loss).

I did the same with my Raspberry Pi 3 Model B+ (using the same Micro SD Card without any modifications to it):

  • Ethernet: 100/100 packets were received (0% loss).
  • WiFi: 100/100 packets were received (0% loss).

Fortunately I was able to exchange my Pi 4 (assuming the physical Ethernet interface was corrupt) for a new Pi 4. Unfortunately the problem still remains.

I tried different (with updated packages) OSs (Raspbian Buster Lite, Raspbian Buster with desktop, Arch Linux ARM), different Micro SD Cards and different Ethernet cables. The used power supplies are the official ones.

The router I am using is provided by my ISP: CH7466CE (I couldn't find an English manual). I was able to get my hands on the predecessor of the CH7466CE, but the Ethernet connection still lost packages.

The Ethernet connection my Pi 4 doesn't seem to work properly. Any idea how I could fix the Ethernet connection? Any ideas how I could narrow down the cause?

  • your results state 0% loss on Ethernet ... yet your text claims packet loss on ethernet ... please fix this as it makes it sound like you don't know what you're doing Commented Sep 11, 2019 at 9:11
  • if two different pi4's behave the same, the problem is likely at your end Commented Sep 11, 2019 at 9:11
  • @JaromandaX Thanks for the hint. I adjusted the corresponding rows. Commented Sep 11, 2019 at 9:16

4 Answers 4


I solved that problem by using a netgear switch behind my ISP's router. The "Unitymedia ConnectBox" in my case generated about 15% packet loss. I experienced all the problems you described and it's really strange that the wifi connection runs just fine. Also RPi1 and 2 worked with my router as well (haven't bought the RPi3).

Try to link your pi's network interface directly with the network interface of your laptop or a desktop and ping each other. if there is no packet loss between the two its your routers fault.

All my network devices are now attached to a NETGEAR GS308-300PES. Even when pinging my Pi from the router thers no packet loss anymore ... hope that helps.

  • 1
    I was able to get my hands on an AVM FRITZ!Box 6490 Cable (router) which solved the problem. Looks like the problem is router specific. Commented Oct 19, 2019 at 8:59

This is likely due to a cable which is only really good for 100Mbps connecting two 1Gbps ports: the devices are able to negotiate a 1Gbps connection, but it works poorly.

Your best option is to get a better Ethernet cable.

Another option is to install ethtool and limit the data rate to 100Mbps with

ethtool -s eth0 speed 100 duplex full autoneg off
  • I just checked the specs of the Ethernet cable and it supports up to 1000Mbps. Commented Sep 11, 2019 at 14:54
  • @MatthiasKuklinski How do you explain packet loss then? Commented Sep 11, 2019 at 18:35
  • 1
    @DmitryGrigoryev I have RPI4 and router which supports only 100Mbps. When I connect rpi to this router, rpi and all other things work poorly and everywhere is big packet loss. After calling this ethtool command it works well but why? Thanks!
    – Matej
    Commented Dec 27, 2019 at 15:30
  • @Matej There are many reasons why speed negotiation could break, and forcing the correct speed is a typical cure. Commented Jan 2, 2020 at 17:55

Just now I used PC Win 10 cmd command ping to ping my Rpi4B raspbian 10 buster (2019jul10) with the following results:

  1. Ethernet (WiFi Disabled) = Zero loss, average < 1ms.

  2. Wifi (Ethernet cable disconnected) = Zero loss, average 1 mS (max 5mS)

I used $ hostanme -I to find Ethernet IP as Wifi

I am using Ethernet ftp for Win10 EditPlus Rpi4B PureFTPd. So far so good.

My CAT5 Cable is 2 metres long. Router NetGear 2018 model (AC1750 Smart WiFi Router R6400) 2/5Gb/s.

Please feel free to let me know to do other tests for your comparison.

PS - I have never pinged Win/Rpi1/2/3/4 these years, because I always find Wifi/Ethernet connection stable. However, I only used SSH very rarely in my Rpi1/2 days. I am not sure if this matters. I have tested four Rpi4B's: 1GB x 2, 2GB x 2 from two vendors (RS and Argon40).


I had same issue with rb pi 4 In local lan i lost almost 1-2 % of ping it was so annoying , i changed mtu for eth0 to 1000 , It didn't go away completely, but it got much, much better

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.