0

I have a Rpi 3B+ that I set up yesterday to work with Kodi as a media center through a WiFi connection. The only problem is that yesterday I could connect via VNC and ssh to the Rpi, and today I can't. I'm getting a "connection refused" message either way.

Since yesterday, when it worked, I have changed absolutely nothing, and before anybody asks I'm aware that ssh and VNC come disabled by default. I activated them when I installed a fresh Raspbian. Today they are still (!) active, in theory. Not in practice, of course.

I have tried rebooting and disabling and enabling ssh and VNC again, but nothing happens. I always get "Connection refused".

Any ideas?

  • Did you reboot your Pi between the time you were last logged on and now? You can always connect the Pi to a screen and plug in a keyboard if you have to. – user96931 Apr 29 at 21:32
0

I found the problem, and it had nothing to do with the Rpi (I'm posting it here just in case somebody else has the same problem).

It was a matter of conflicting (i.e., equal) IP addresses, that were assigned through DHCP. I set the new conflicting IP as static (with a different number) and solved the problem.

| improve this answer | |
  • Please accept your own answer with a click on the tick on its left side. Only this will finish the question and it will not pop up again year for year. – Ingo May 4 at 18:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.