I've tried setting up the Media Centre HAT from Pi Supply but cannot get the TFT screen to function at all. The touch control works out of the box (resistive) and the rotation of the touch controls also functions after the setup but I haven't seen anything on the screen itself.

I've had a go using the Pi Supply tutorials, and the ones that they quote here.

Originally I tried to set this up in Ubuntu (not officially supported) but have also not managed to get it working with Raspberry Pi OS Lite/Normal/Full, LibreELEC and even the latest image from here.

The only error I see when the script runs is: E: Unable to locate package rbp-userland-dev-osmc but on the OSMC website it says that it hasnt been updated for the Raspberry Pi 4, and Pi Supply say that they have tested their setup on Buster and say that this HAT is compatible with the Raspberry Pi 4 so I think this is an optional package? I have been unable to find a repository to install it on my device.

On the Raspberry Pi configuration settings I've enabled all interfaces (apart from SSH) to see if that made any difference but it didn't.

Any help people have on this would be great! In theory this is meant to be easy so I have no idea how I've managed to make it so complicated.

OS and Kernel Version

pi@raspberrypi:~ $ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 10 (buster)"
NAME="Raspbian GNU/Linux"
VERSION="10 (buster)"
pi@raspberrypi:~ $ uname -r

Pi Supply automated Script output

pi@raspberrypi:~ $ sudo su -c "bash <(wget -qO- https://pisupp.ly/mediacentersoftware)" root
Hit:1 http://raspbian.raspberrypi.org/raspbian buster InRelease
Hit:2 http://archive.raspberrypi.org/debian buster InRelease
Reading package lists... Done
Select one of the options below:
[0] - Portrait
[90] - Horizontal (Default)
[180] - Portrait Reverse
[270] - Horizontal Reverse
Option: 90
--- /usr/share/X11/xorg.conf.d/ ---

-layout TFT
-layout HDMI (Select for fbcp use)
-layout HDMITFT
When -layout is not set in lightdm, the first is used: TFT
Select your prefered layout:
1. TFT Output Only
2. HDMI Output Only (select for fbcp)
3. HDMI(Primary) & TFT(extension) 
Activate the console on the TFT display? y/n n
Install fbcp (Framebuffer Copy)? y/n y
--- Installing fbcp ---
Installing FBCP on OMSC
Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package rbp-userland-dev-osmc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
build-essential is already the newest version (12.6).
git is already the newest version (1:2.20.1-2+deb10u3).
The following additional packages will be installed:
  cmake-data libjsoncpp1 librhash0 libuv1
Suggested packages:
  cmake-doc ninja-build
The following NEW packages will be installed:
  cmake cmake-data libjsoncpp1 librhash0 libuv1
0 upgraded, 5 newly installed, 0 to remove and 0 not upgraded.
Need to get 4,330 kB of archives.
After this operation, 21.8 MB of additional disk space will be used.
Get:1 http://raspbian.mirror.uk.sargasso.net/raspbian buster/main armhf cmake-data all 3.13.4-1 [1,476 kB]
Get:2 http://raspbian.mirror.uk.sargasso.net/raspbian buster/main armhf libjsoncpp1 armhf 1.7.4-3 [66.2 kB]
Get:3 http://raspbian.mirror.uk.sargasso.net/raspbian buster/main armhf librhash0 armhf 1.3.8-1 [132 kB]
Get:4 http://raspbian.mirror.uk.sargasso.net/raspbian buster/main armhf libuv1 armhf 1.24.1-1 [96.7 kB]
Get:5 http://raspbian.mirror.uk.sargasso.net/raspbian buster/main armhf cmake armhf 3.13.4-1 [2,559 kB]
Fetched 4,330 kB in 1s (4,309 kB/s)
Selecting previously unselected package cmake-data.
(Reading database ... 98393 files and directories currently installed.)
Preparing to unpack .../cmake-data_3.13.4-1_all.deb ...
Unpacking cmake-data (3.13.4-1) ...
Selecting previously unselected package libjsoncpp1:armhf.
Preparing to unpack .../libjsoncpp1_1.7.4-3_armhf.deb ...
Unpacking libjsoncpp1:armhf (1.7.4-3) ...
Selecting previously unselected package librhash0:armhf.
Preparing to unpack .../librhash0_1.3.8-1_armhf.deb ...
Unpacking librhash0:armhf (1.3.8-1) ...
Selecting previously unselected package libuv1:armhf.
Preparing to unpack .../libuv1_1.24.1-1_armhf.deb ...
Unpacking libuv1:armhf (1.24.1-1) ...
Selecting previously unselected package cmake.
Preparing to unpack .../cmake_3.13.4-1_armhf.deb ...
Unpacking cmake (3.13.4-1) ...
Setting up libuv1:armhf (1.24.1-1) ...
Setting up librhash0:armhf (1.3.8-1) ...
Setting up cmake-data (3.13.4-1) ...
Setting up libjsoncpp1:armhf (1.7.4-3) ...
Setting up cmake (3.13.4-1) ...
Processing triggers for man-db (2.8.5-2) ...
Processing triggers for libc-bin (2.28-10+rpi1) ...
Cloning into 'rpi-fbcp'...
remote: Enumerating objects: 7, done.
remote: Counting objects: 100% (7/7), done.
remote: Compressing objects: 100% (5/5), done.
remote: Total 7 (delta 1), reused 6 (delta 1), pack-reused 0
Unpacking objects: 100% (7/7), done.
-- The C compiler identification is GNU 8.3.0
-- The CXX compiler identification is GNU 8.3.0
-- Check for working C compiler: /usr/bin/cc
-- Check for working C compiler: /usr/bin/cc -- works
-- Detecting C compiler ABI info
-- Detecting C compiler ABI info - done
-- Detecting C compile features
-- Detecting C compile features - done
-- Check for working CXX compiler: /usr/bin/c++
-- Check for working CXX compiler: /usr/bin/c++ -- works
-- Detecting CXX compiler ABI info
-- Detecting CXX compiler ABI info - done
-- Detecting CXX compile features
-- Detecting CXX compile features - done
-- Configuring done
-- Generating done
-- Build files have been written to: /tmp/rpi-fbcp/build
Scanning dependencies of target fbcp
[ 50%] Building C object CMakeFiles/fbcp.dir/main.c.o
[100%] Linking C executable fbcp
[100%] Built target fbcp
Enable automatic startup of fbcp on boot? y/n y
Note: The console output on the TFT display will be disabled.
Install xinput-calibrator? y/n n
Enable onboard Joystick/Buttons? y/n n
Configure MCH IR Remote? y/n n
Reboot the system now? y/n
  • if the display does not work, then how do you know that the touch panel works correctly? ... did you forget to include some information?
    – jsotola
    Commented Dec 12, 2020 at 18:53
  • This setup is meant to mirror the HDMI output to the TFT screen using fbcp, so I can still see the original HDMI output on the main screen but nothing on the mini TFT. I found the issue and solution (and posted in the github repository for this HAT). I will copy it here Commented Dec 13, 2020 at 12:44

1 Answer 1


So I've managed to fix it.

I went through the manual process again and had to add a few stages / install some drivers / etc. I used the instructions from this link to get the display drivers I needed, I've copied the commands below but for a full explaination follow the link.

sudo apt-get install git build-essential xorg-dev xutils-dev x11proto-dri2-dev
sudo apt-get install libltdl-dev libtool automake libdrm-dev
git clone https://github.com/ssvb/xf86-video-fbturbo.git
cd xf86-video-fbturbo
autoreconf -vi
./configure --prefix=/usr
sudo make install
sudo cp xorg.conf /etc/X11/xorg.conf

I then followed the manual process but edited the configuration files at these locations (they're slightly different from the ones listed in the manual guide).

sudo nano /etc/X11/xorg.conf 
sudo nano /etc/lightdm/lightdm.conf

Hopefully It was just a unique issue to me, but if not maybe this will help someone in the future!

  • 1
    Please mark the answer as the accepted one with a click on the tick on its left side. That prevents your Question from being shown as an unsolved Post to the community and saves them/us a lot of work.
    – Ingo
    Commented Dec 20, 2020 at 11:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.