0

wondering if someone can help.

Setting up a seedbox and getting the last few things ironed out

have a sata hat raid that i've got to mount using systemd however when I reboot minidlna and qbittorrent load before the sata hat mounts the raid which causes issues (qbittorrent then can't find the file paths etc)

Wondering if anyone can help with systemd to get minidlna & qbittorrent to load only after the raid has mounted

currently:

"# This file is part of systemd.

systemd is free software; you can redistribute it and/or modify it under the terms of the GNU Lesser General Public License as published by the Free Software Foundation; either version 2.1 of the License, or (at your option) any later version. [Unit] DefaultDependencies=no Conflicts=umount.target After=rockpi-sata.service Before=local-fs.target umount.target

[Mount] What=/dev/md0 Where=UUID=“3c3a3c08-2aff-4bd6-a68c-5ad8eddb2123” Type=ext4 Options=defaults,noatime

Make ‘systemctl enable mnt-raidx.mount’ work: [Install] WantedBy=local-fs.target"

mounts to /mnt/raidx""

If anyone is able to help it would be greatly appreciated I've spent nearly 100+ hours and countless weekends trying to get numerous things to work and if anyone can save me some time that would be fantastic

Basically want qbittorrent to only load once /mnt/raidx has been mounted and same for minidlna

so if I get a power outage or reboot things just automatically for me

I'm having to use system md due to the sata hat not loading straight away

1
  • Hi, your question is rather hard to read. Did you change config files or created new ones? Which part of your question corresponds to configuration files, shell commands, error messages? How do you expect your system to work, and what is the behavior you get instead? Dec 17, 2020 at 14:24

1 Answer 1

2

For my understanding to mount a local attached device, the local filesystem (local-fs.target) must be available, so the mount should be done After=local-fs.target. Try to replace the line:

Before=local-fs.target umount.target

with

After=local-fs.target

in the Unit file.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.