1

I have successfully removed the logo and added a splash screen. But I still get text output before and after the splash image.

I am using Raspbian Jessie Lite and I think that this has something to do with systemd. So I tried the instructions from this page.

This is my commandline.txt

dwc_otg.lpm_enable=0 console=ttyAMA0,115200 console=tty3 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes quiet loglevel=0 rd.systemd.show_status=false vt.global_cursor_default=0 logo.nologo rootwait

I have also removed the plymouth and plymouth-show scripts from /etc/init.d/

No text should be seen now, but I still do get it. Why? How can I get a completely clean boot with only the splash image.

3
  • Sorry I can't solve issue for you but here are my two cents: I had same issue and somehow I resolved it - I don't remember how. It was something with tweeking kernel options and something with fb, but don't take my words for 100% true. It is possible and you should only see log on tty3 with your config while your HDMI output (tty1) should be clean.
    – 10robinho
    Oct 20 '16 at 14:39
  • by the way, do you see only systemd log or you also see kernel log on your tty1? because with your cmdline.txt there should be no kernel log on tty1. There is /etc/inittab file where this stuff can be tweeked, but I don't know if systemd uses it or something else
    – 10robinho
    Oct 20 '16 at 14:41
  • I think I get both. I get messages like: Reached target Local File Systems (Pre). Found device /dev/ttyAMA0 Started Show Plymouth Boot Screen etc I even took out Plymouth from the init.d scripts and still there are messages. I have no clue what is going on.
    – hp07
    Oct 20 '16 at 14:44
1
sudo apt-get purge --remove plymouth

Solved it. Thanks to robinho for the idea.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.