2

I tried using the wiringPi GPIO library just to test some basic IO, but when I tried to output HIGH on a pin (GPIO 25) the voltage only went from 0V to 0.03V, is this normal?

If this is normal that's rather useless because I cannot bit bang anything at those levels, right?

6
  • BCM GPIO25 or pin 25? As pin 25 is the GND pin, so always 0volts. (Pin numbering is totally insane. Physical pin 22, is GPIO 6 on the pi, and GPIO 25 on the BroadCom chip.)
    – Gerben
    Nov 28, 2013 at 16:44
  • I am using GPIO 25 as in Broadcom numbering
    – Gerharddc
    Nov 28, 2013 at 16:50
  • So pin 22. That is definitely not normal. Output voltages should be 3.3V. Have you tried a different pins?
    – Gerben
    Nov 28, 2013 at 17:48
  • It seems all seems to work after a reboot
    – Gerharddc
    Nov 28, 2013 at 18:53
  • Glad you got it working.
    – Gerben
    Nov 28, 2013 at 19:18

1 Answer 1

0

Very strange but a reboot seemed to fix the issue, so if you also have it, try rebooting!

1
  • 3
    By the way, if you've resolved this issue, could you please mark this answer as such? That would be great :) Apr 1, 2014 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.