0

Reason For Pi4

I'm trying to setup a headless fileshare/music server

Setup

A Pi 4 Model B 8GB inside a DeskPi Pro Case, all connected to a Tripp-Lite B004-HUA4-K containing a Crucial SSD. I haven't even attempted to setup the SSD, because I'm attempting to update first, which is failing.

Setup 2

A Geekworm X825 in combination with a Geekworm X735 in an X825-C6 Case. Setup 2 is failing in the same way as Setup 1

Network Setup

(edit)

AT&T DSL Modem(Port4) --> Netgear 16 port auto sensing switch --> 2 Ethernet ports into my bedroom

I know this setup works because the desktop I'm writing this on is connected along with a Macbook

Issues

  1. I've got a standard Cat5e Cable plugged into a switch in my attic. When I move that cable from my laptop to the Pi, the ethernet status lights don't come on. If I reconnect it to the laptop I do see lights on the laptop. Do I need something extra to enable the port?
  2. When using onboard wireless, because of 1, the Pi refuses to connect to a secured network set to use WPA2. I know the password is correct because it's the factory default for my ISP's modem (the one on the sticker...). I know it works, because if I run any bootstrapper(NOOBS, berryboot, etc), the OS'es are downloaded and installed, but once the install completes, and the fresh install boots, the card is stuck trying to connect. I did see something on my last Debian attempt about the RFKILL switch.
  3. I also have an extra Pi and a GeekWorm X.255 Hat and case I can use, if I can't get this working.

Any help would be appreciated. I'll be checking this on my days off (1-28, 1-29), when I can devote time to troubleshoot extensively.

Thanks

10
  • Appears you have a network config. problem. Have you made any changes to your RPi that might affect networking operation? Has it ever been connected to a network? Can you connect to it at all - from any location? Have you run the ip -a command?
    – Seamus
    Jan 27 at 5:50
  • Just got home from work. This is a fresh build, less than a month old. I can connect wirelessly from NOOBS, and or BerryBoot, but never after an install. NOOBS and BerryBoot both don't see an Ethernet Cable. As for changes, I followed the installation instructions exactly, so I've changed nothing.
    – eyoung100
    Jan 27 at 21:58
  • OK - I'm confused already... What do NOOBS & BerryBoot have to do with this? Why have you not just d/l and install on of the RPi OS distros?
    – Seamus
    Jan 27 at 22:04
  • I apologize if I was unclear: I used NOOBS and BerryBoot to see if I could get Wireless working, which it does, but only during the bootstrapping process. NOOBS and BerryBoot both download the OS before installing it (See Issue 2). I've downloaded and installed Rasbian32 once, Ubuntu twice, and the Rasbian 64 beta once. Each install fails in the issues described above.
    – eyoung100
    Jan 27 at 22:15
  • I've never used NOOBS or BerryBoot; I've heard some disparaging remarks, but I know nothing from personal experience. As a suggestion, you might try installing one of the distributions, and follow the installation instructions that everyone else seems to manage without much help. I just visited the "official" website, and this page looks like a reasonable place to begin the install of your OS to the SD card.
    – Seamus
    Jan 27 at 22:24
1

From the chat session, it seems you have overlooked the necessity to create the ssh file in the /boot partition of the SD card. This is done while the SD card is still mounted in your PC (Mac, Windows, Linux). /boot is formatted as a FAT32 partition, so it may be read and written by virtually any computer on earth.

To create the ssh file, simply mount the SD card, and add/copy/move an empty file named ssh to /boot.

The presence of the file named ssh in /boot is a flag to the system: it tells the system to start the SSH server during the boot process. The system actually deletes the ssh file during the first boot as it's no longer needed; SSH is configured to start at each boot afterwards.

If you plan on using wireless, you will also need to create the wpa-supplicant.conf file. Instructions for creating this file may be found here.

All of that said, your question raises other potential issues, but we can cover those once we get your RPi booted, and answering SSH calls.

1
  • I created the SSH file, and connected a monitor. I logged in as root. The boot process is stuck trying to fetch an IP. I switched to a terminal, and issued an ifup --force which fails with no responses. I'll update my question with my network layout, in case that helps
    – eyoung100
    Jan 29 at 21:50
0

I solved this by getting a lead over at the Pi Forums. See Ethernet Problems. It turns out my Ethernet is only running at 10/100. The Broadcom Chipset on the Pi4 doesn't support fallback from Gigabit to Fast Ethernet. As such I bought a USB 3.0 to Gigabit Ethernet Adapter TU3-ETG, which does support fallback, and is supported by the upstream linux kernel, and therefore the Pi kernel.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.