1

I was using micropython at the time it stopped working. the pico used to work. it stopped working. when i insert the pico, windows gives me a message saying that the device cannot be recognized. in device manager it is also unrecognized.

if i unplug the pico and press bootsel, then plug it back in, after a short time, windows says that it doesnt recognize the device.

I do not believe that the cables are the issue. it worked before and the cables works on other devices that need data.

at this time, all the answers that i can find are to press bootsel or make sure the usb cable has data and power or to pull "run" to ground and press stop on thonny. neither have worked.

possibly what caused the mishap was an error in a line of code. for the ssd1306 fill(), it takes a 0 or a 1. i put a 11 on accident. i would think that this would simply cause an error, but maybe not.

*update- I tried it on another computer and it worked. but 10 minutes later it stopped working and now it wont work on either computer

3
  • 1
    @tlfong01, I had done no soldering, I have already tried different USB cables. The info in the link doesnt help me. thanks anyways
    – Zeno
    Apr 3, 2021 at 20:02
  • One possibility is that your USB cable is too long and wiring inside is too thin. I remember in my Rpi 1 days, I used long USB cables to power the Rpi 1 and found Rpi not stable. Later I found that my USB 5V dropped to below 4.8V and Rpi was not stable. So my lesson learnt is to use very short USB cables.
    – tlfong01
    Apr 5, 2021 at 5:44

2 Answers 2

1

Not sure what else there is to say.

  1. Unplug the USB cable to the device

  2. Hold bootsel down

  3. Replug the USB cable to the device

  4. Wait half a second

  5. Release bootsel

If that doesn't work reboot your Windows PC.

If that doesn't work try another PC.

5
  • 1
    and if that doesn't work, try another PICO :p Apr 1, 2021 at 8:54
  • Haha. Looks like I might have to try another pico :(
    – Zeno
    Apr 1, 2021 at 14:34
  • What you did should not have broken the pico. Have you removed all wiring to the pico (other than the USB supply)?
    – joan
    Apr 1, 2021 at 15:45
  • Yeah. Btw it still runs the code. Its just that my pc doesn't recognize it. I'll try another computer when I get back
    – Zeno
    Apr 1, 2021 at 18:19
  • I tried it on another computer and it worked. but 10 minutes later it stopped working and it wont work on either computer
    – Zeno
    Apr 2, 2021 at 3:13
0

Yesterday I started testing the I2C OLED SSD1308.

I did test it successfully some two years ago using Rp4B. So I though this should be easy. But immediately after I plugged in power 5V, my finger felt hot, and even the the OLED panel was hot (not just warm!).

I checked the datasheet again and found its spec for Vcc is 3~5V.

Your test results seems to suggest that your device also cannot stand 5V. So it was getting hot, and fried or get crazy after a few minutes.

4
  • 1
    maybe it did get damaged. I've basically assumed that it is dead now.
    – Zeno
    Apr 5, 2021 at 3:05
  • Just a quick comment. (1) I did not read your question too carefully. I wrongly thought that you fried an I2C device, not the Pico itself. (2) I think the pico is not dead, for the following reasons: (a) If you only used Win10 USB cable to connect to Pico, then only USB 5V should be powering the Pico, so there is little chance of any over voltage, (b) Pico is made in Sony, Wales UK (I think, only 50% sure), with good QC, so not much chance of fring accidentally), (3) The USB cable should not have too thin wires, because it powers a MCU, not a baby smart phone. / to continue, ...
    – tlfong01
    Apr 5, 2021 at 3:25
  • (4) One way to check out is use external 5V PSU to power the Pico, (5) One other possibility is the following: A thin PCB trace or connecting wire is partically broken in the middle, but not fallen into two pieces, and still somehow "touchingly" connected. Now then it is passing current, heating up the broken joint, then making things worse, perhaps as you say, work for a while, then stopped working, or finally go flat dead.
    – tlfong01
    Apr 5, 2021 at 3:25
  • (5) Pico still have many teething problems. One trick is to regularly update the UF2 file (Only most updated "unstable" version are stable. :)
    – tlfong01
    Apr 5, 2021 at 5:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.